Ask Your Question

Revision history [back]

It is a known problem in groovy, that rgbdslam doesn't find libg2o. A hackish solution that worked for one person and didn't work for a second one is this:

delete the following line in rgbdslam/CMakeLists.txt

find_package(libg2o REQUIRED)

replace the following line

SET(G2O_LIBS ${libg2o_LIBRARIES} cholmod cxsparse)

by

SET(G2O_LIBS cholmod cxsparse -lg2o_cli -lg2o_core
-lg2o_csparse_extension -lg2o_ext_freeglut_minimal -lg2o_incremental
-lg2o_interactive -lg2o_interface -lg2o_opengl_helper -lg2o_parser
-lg2o_simulator -lg2o_solver_cholmod -lg2o_solver_csparse
-lg2o_solver_dense -lg2o_solver_pcg -lg2o_solver_slam2d_linear
-lg2o_solver_structure_only -lg2o_stuff -lg2o_types_data -lg2o_types_icp
-lg2o_types_sba -lg2o_types_sclam2d -lg2o_types_sim3 -lg2o_types_slam2d
-lg2o_types_slam3d)

I am not using groovy but I will happily patch rgbdslam if someone has a reliable solution to this.