ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

cant install ROS on VirtualBox/Ubuntu 12.04

asked 2013-08-26 03:44:14 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello. I've tried to install ROS for the last two days, followed a few guides, tried to type in the installation commands in the ubuntu terminal a thousand times. I have virtualbox installed I have the extension packages installed I have installed ubuntu 12.04 I have checked: mail, universe, restricted and multiverse in the software sources and unchecked the installable cd/dvd. I have updated in terminal by executing the sudo apt-get update command everytime I enter this command: "the normal installation command" Nothing happens, just a new line with: ubuntu@ubuntu:~$ starts.

I cant post webadresses..

Another isues I also have is my keyboard has all the special signs like: _/(=&/¤*^" etc. swicted around, so I have to guess where they know are hidding even through I have my own country keyboard layout configurated, so what can that be all about? Im so frustrated right now, so hope somebody can help me, I have tried google alot without any concrete help. Best regards.

edit retag flag offensive close merge delete



can you poste might a little more information ? what is the output if you enter which command, for example "sudo apt-get install ros-groovy-desktop"

pkohout gravatar image pkohout  ( 2013-08-26 04:53:03 -0500 )edit

Please check the support guidelines: to get useful help. You need to give some concrete information what you tried to do and what failed.

dornhege gravatar image dornhege  ( 2013-08-26 05:00:53 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2013-08-26 07:18:56 -0500

dornhege gravatar image

If you are following the guide at:

It is important that you follow all steps and in the right order. You are missing some, e.g. the apt-get update. If you follow each step, everything should go well. If there are errors, please report them here including the commands you issued.

edit flag offensive delete link more


I was told at Ubuntu's forum, that I should just go to next step and keep on. it worked lol. now my problem is that I doesnt have enough space on my drive. I'll see if I can fix it by google. thanks so far for all your help! (:

Dynamitetalks gravatar image Dynamitetalks  ( 2013-08-26 07:31:47 -0500 )edit

answered 2013-08-26 04:42:51 -0500

Dynamitetalks gravatar image

updated 2013-08-26 06:17:23 -0500

Sorry for the multiply posting, I got an error message 10 times..

Thanks for your responses:

I can't post a screenshot since my karma is too low. so here is what is written in ubuntu terminal ->

First typed the command you ask for what happen and second the "normal install" command:

ubuntu@ubuntu:~$ sudo apt-get install ros-groovy-desktop Reading packages lists... Done Building dependency tree Reading state information... Done E: Unable to locate package ros-groovy-desktop ubuntu@ubuntu:~$ sudo sh-c 'echo "deb precise main" > /etc/apt/sources.list.d/ros-latest.list

Anything else I can do to give you a better idea of the problem?

Should I locate the ros install file on my desktop?

edit flag offensive delete link more


Please update your original post with this information instead of posting it as an answer.

dornhege gravatar image dornhege  ( 2013-08-26 07:17:03 -0500 )edit

Question Tools



Asked: 2013-08-26 03:44:14 -0500

Seen: 253 times

Last updated: Aug 26 '13