Ask Your Question
0

turning laser check box on in rviz cause python fault [closed]

asked 2013-08-25 03:13:46 -0600

rnunziata gravatar image

Turning laser check box on in rviz cause python fault. If I leave it off then the rivz if fine I can even use the map function and it shows the laser data mapping. But turn of the Laser check box and rviz goes down with the error below.

Laser Pose= -6.03836 1.0032 0.0265495
Registering Scans:Done
*** glibc detected *** python: double free or corruption (!prev): 0x0bb29b00 ***
======= Backtrace: =========
[rqt_gui-1] process has died [pid 27971, exit code -11, cmd /opt/ros/hydro/lib/rqt_gui/rqt_gui __name:=rqt_gui __log:=/home/rnunziata/.ros/log/125624be-0d86-11e3-bbbe-000c29589865/rqt_gui-1.log].
log file: /home/rnunziata/.ros/log/125624be-0d86-11e3-bbbe-000c29589865/rqt_gui-1*.log



  <gazebo reference="hokuyo_link">
    <sensor type="ray" name="head_hokuyo_sensor">
      <visualize>true</visualize>
      <update_rate>40</update_rate>
      <ray>
        <scan>
          <horizontal>
            <samples>720</samples>
            <resolution>1</resolution>
            <min_angle>-1.570796</min_angle>
            <max_angle>1.570796</max_angle>
          </horizontal>
        </scan>
        <range>
          <min>0.10</min>
          <max>30.0</max>
          <resolution>0.01</resolution>
        </range>
        <noise>
          <type>gaussian</type>
          <!-- Noise parameters based on published spec for Hokuyo laser
               achieving "+-30mm" accuracy at range < 10m.  A mean of 0.0m and
               stddev of 0.01m will put 99.7% of samples within 0.03m of the true
               reading. -->
          <mean>0.0</mean>
          <stddev>0.01</stddev>
        </noise>
      </ray>
      <plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_laser.so">
        <topicName>/scan</topicName>
        <frameName>hokuyo_frame</frameName>
        <robotNamespace>/rrbot</robotNamespace>
      </plugin>
    </sensor>
  </gazebo>
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rnunziata
close date 2013-09-11 02:06:33

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-11 02:06:19 -0600

rnunziata gravatar image

fixed after upgrade

edit flag offensive delete link more

Comments

what did you upgrade ? i have also similar problem.

fatihx gravatar imagefatihx ( 2013-09-17 01:38:27 -0600 )edit

I was running hydro under VMWare at the time. All I did was a apt-get upgrade . Since then I have switched to a full dual boot. And that solved a lot of problems.

rnunziata gravatar imagernunziata ( 2013-09-17 02:54:21 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-08-25 03:13:46 -0600

Seen: 117 times

Last updated: Sep 11 '13