Ask Your Question
0

Can't locate node sick_tim3xx in package sick_tim3xx

asked 2013-08-16 16:39:39 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I'm using the SICK_TIM310 laser scanner using ROS Fuerte. I have tried installing the appropriate package from github using (I didn't include the https:// at the start because my karma is insufficient)

svn co github.com/uos/sick_tim3xx.git

in my stacks folder and everything went fine until I tried

roslaunch sick_tim3xx sick_tim3xx.launch

I get an error saying that sick_tim3xx is not a package eventhough it was in my stacks folder. As a result, I tried downloading the files in a zip file from github and unzipped it to the stacks folder and roslaunch works fine but I get the following error now;

core service [/rosout] found

process[robot_state_publisher-1]: started with pid [27496]

ERROR: cannot launch node of type [sick_tim3xx/sick_tim3xx]: can't locate node [sick_tim3xx] in package [sick_tim3xx]

So looks like it is unable to find the sick_tim3xx node. Could I please get some assistance on how to solve this?

edit retag flag offensive close merge delete

Comments

hello, I have the same problem with you. Did you solve this problem? Could you tell me how?

dido_yf gravatar image dido_yf  ( 2014-12-18 04:28:40 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-11-13 23:21:15 -0500

You didn't build your package. Run rosmake sick_tim3xx.

edit flag offensive delete link more
0

answered 2014-12-18 05:55:27 -0500

aviprobo gravatar image

updated 2014-12-18 06:06:28 -0500

Hi, if you followed the steps I took, did you run "rosmake sick_tim3xx" ? Make sure you added the directory path of the sick directory to your .bashrc path.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-16 16:39:39 -0500

Seen: 723 times

Last updated: Nov 13 '13