Ask Your Question
0

SSH error when launching nodes on another machine

asked 2013-08-12 13:33:56 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

We added this line to our launch file in order to run a node on another machine:

<machine name="robot" address="robot.dynamic.edu" env-loader="/opt/ros/groovy/env.sh" user="turtlebot"/>

The problem is we get this error:

<a href="http://robot.dynamic.edu">robot.dynamic.edu</a> is not in your SSH known_hosts file.

Please manually:
   ssh <a href="mailto:turtlebot@robot.dynamic.edu">turtlebot@robot.dynamic.edu</a>

then try roslaunching again.

If you wish to configure roslaunch to automatically recognize unknown hosts, please set the environment variable ROSLAUNCH_SSH_UNKNOWN=1

Our environment variable is set to:

#!/usr/bin/env sh
# generated from catkin/cmake/templates/env.sh.in

if [ $# -eq 0 ] ; then
   /bin/echo "Usage: env.sh COMMANDS"
   /bin/echo "Calling env.sh without arguments is not supported anymore. Instead spawn a subshell and source a setup file manually."
   exit 1
else
  . "/opt/ros/groovy/setup.sh"
  exec "$@"
fi
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-13 05:25:08 -0500

tbh gravatar image

Linux doesn't know what computer robot.dynamic.edu refers to, and so you have to tell it. You do so by editing your /etc/hosts file like they do in this explanation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-08-12 13:33:56 -0500

Seen: 976 times

Last updated: Aug 13 '13