Ask Your Question
0

Shell script in rosdep rule error

asked 2013-08-06 12:58:47 -0500

130s gravatar image

updated 2013-08-06 23:25:47 -0500

Update The similar error happens even with the rule that's already commited. For example on Ubuntu, add glc (link to rosdep rule) as dependency in package.xml and rosdep your package (in my case I arbitrarily used rqt_plot again). Should I open a ticket?

$ rosdep install rqt_plot -s
#[apt] Installation commands:
  sudo apt-get install ros-hydro-rqt-gui
  sudo apt-get install python-matplotlib
  sudo apt-get install update
sudo
  sudo apt-get install ros-hydro-rqt-py-common
  sudo apt-get install ppa:arand
sudo
  sudo apt-get install sudo
  sudo apt-get install ros-hydro-rostopic
  sudo apt-get install ros-hydro-qt-gui-py-common
  sudo apt-get install python-rospkg
  sudo apt-get install ros-hydro-rqt-gui-py
  sudo apt-get install ros-hydro-rosgraph
  sudo apt-get install install
  sudo apt-get install #!/bin/bash
yes
  sudo apt-get install ros-hydro-catkin
  sudo apt-get install glc

  sudo apt-get install python-qwt5-qt4
  sudo apt-get install -y
  sudo apt-get install |
  sudo apt-get install apt-add-repository
  sudo apt-get install apt-get

package.xml

  :
  <run_depend>glc</run_depend>
  :

Initial post

Embedding a shell script into rosdep rule, then rosdep install rqt_plot returns the following and obviously fails. What is wrong?

executing command [sudo apt-get install then
]

The following seems all what happens. Looks entirely corrupted:

$ rosdep install rqt_plot -s
#[apt] Installation commands:
  sudo apt-get install then

  sudo apt-get install 
  sudo apt-get install python-matplotlib
  sudo apt-get install -i
  sudo apt-get install sudo
  sudo apt-get install ros-hydro-rostopic
  sudo apt-get install cd
  sudo apt-get install ros-hydro-rqt-gui
  sudo apt-get install fi

  sudo apt-get install if
  sudo apt-get install !
  sudo apt-get install -f
  sudo apt-get install #!/bin/bash
if
  sudo apt-get install ]
  sudo apt-get install mkdir
  sudo apt-get install -p
  sudo apt-get install ros-hydro-rqt-py-common
  sudo apt-get install ros-hydro-catkin
  sudo apt-get install ;
  sudo apt-get install /usr/lib/pymodules/python2.7/pyqtgraph
  sudo apt-get install ~/.ros/rosdep/tmp
  sudo apt-get install ros-hydro-rqt-gui-py
  sudo apt-get install python-rospkg
  sudo apt-get install ~/.ros/rosdep/tmp

  sudo apt-get install <a href="http://www.pyqtgraph.org/downloads/python-pyqtgraph_0.9.7-1_all.deb">http://www.pyqtgraph.org/downloads/python-pyqtgraph_0.9.7-1_all.deb</a>

  sudo apt-get install wget
  sudo apt-get install [
  sudo apt-get install python-qwt5-qt4
  sudo apt-get install python-pyqtgraph_0.9.7-1_all.deb
fi

  sudo apt-get install dpkg
  sudo apt-get install --tries=10
  sudo apt-get install ros-hydro-qt-gui-py-common
  sudo apt-get install ros-hydro-rosgraph

Script looks as follows (link to repo), or I tried several changes. See Aug 06 2013 for them:

pyqtgraph:
  debian: []
  ubuntu: |
    #!/bin/bash
    if [ ! -f /usr/lib/pymodules/python2.7/pyqtgraph ] ; then
      if [ ! -f ~/.ros/rosdep/tmp ] ; then
        mkdir -p ~/.ros/rosdep/tmp
      fi
      cd ~/.ros/rosdep/tmp
      wget --tries=10 <a href="http://www.pyqtgraph.org/downloads/python-pyqtgraph_0.9.7-1_all.deb">http://www.pyqtgraph.org/downloads/python-pyqtgraph_0.9.7-1_all.deb</a>
      sudo dpkg -i python-pyqtgraph_0.9.7-1_all.deb
    fi

This piece of script (from shebang until fi) runs fine and does what it's supposed to do when I give it to terminal.

I added the following in the package.xml needless to mention.

  <run_depend>pyqtgraph</run_depend>

Also modified is this:

$ more /etc/ros/rosdep/sources.list.d/20-default.list
# os-specific listings first
yaml <a href="https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml">https://github.com/ros/rosdistro ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-08-07 08:15:05 -0500

tfoote gravatar image

Bash scripts are not supported in Fuerte and newer: http://www.ros.org/reps/rep-0111.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-06 12:58:47 -0500

Seen: 424 times

Last updated: Aug 07 '13