Ask Your Question
1

ROS Beginner Tutorials: Examining the Simple Service and Client (python) - need some help with Client 2

asked 2013-08-05 10:16:34 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hey guys,

I'm following the ROS Tutorials and, using the Python language, I'm currently having some issues trying to solve the item Examining the Simple Service and Client item (<link>http ://www.ros .org/wiki/ROS/Tutorials/ExaminingServiceClient</link>). I was already having a problem with the server in this tutorial, but it was solved in another thread (in link text)

My situation is the following:

  • I run roscore in a terminal
  • I run the server (rosrun beginner_tutorials add_two_ints_server.py) in another, getting Ready to add two ints.
  • But when I try to run the client (rosrun beginner_tutorials add_two_ints_client.py 1 3), I get the following:

    [rospack] Error: stack/package beginner_tutorials not found

Running roswtf gives me the following:

viki@ROS:~/catkin_ws/src/beginner_tutorials/scripts$ roswtf
Package: beginner_tutorials
Cannot find dependencies for package [beginner_tutorials]: missing beginner_tutorials
ROS path [0]=/opt/ros/groovy/share/ros
ROS path [1]=/opt/ros/groovy/share
ROS path [2]=/opt/ros/groovy/stacks
viki@ROS:~/catkin_ws/src/beginner_tutorials/scripts$

Can anybody help me? I haven't found any clues on the web related to this and I can't figure it out what's really happening.

Can anyone help me? Thanks in advance,

Batta

edit retag flag offensive close merge delete

Comments

1

what is the output of `export | grep ROS`?

gustavo.velascoh gravatar imagegustavo.velascoh ( 2013-08-05 10:47:11 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
5

answered 2013-08-06 18:57:59 -0600

I agree with Gustavo's suggestion. It seems to me that your $ROS_PACKAGE_PATH is probably not set correctly in the terminal you're using to run the client.

It looks like you're using catkin. Remember that you need to source the catkin workspace setup.bash file in each new terminal (source ~/catkin_ws/devel/setup.bash). This will update the $ROS_PACKAGE_PATH for that terminal. You can check this using the command Gustavo referenced above: export | grep ROS_PACKAGE_PATH. Also, rospack find beginner_tutorials should find the correct path to your package.

I can't see where this requirement is covered explicitly in the ROS tutorials. You can see some hints when reading through this section, but it could definitely be made more clear.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-05 10:16:34 -0600

Seen: 2,439 times

Last updated: Aug 06 '13