Ask Your Question
2

roslaunch openni_launch openni.launch no devices connected

asked 2013-08-01 16:19:24 -0500

Andrew.A gravatar image

updated 2013-08-01 16:22:54 -0500

I'm just starting out trying to use ROS with my Primesense device (Asus Xtion Pro Live) on Ubuntu 12.10 and ROS groovy. I'm trying to perform

roslaunch openni_launch openni.launch

but I'm faced with

[ INFO] [1375408552.874803204]: No devices connected.... waiting for devices to be connected

This is the output of lsusb:

Bus 001 Device 008: ID 1d27:0601  
Bus 005 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 005 Device 003: ID 0461:4d22 Primax Electronics, Ltd 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

It seems like my Primesense device isn't recognised (first row above). The question is, where can I download the appropriate drivers? I'm a bit confused because I can run ./SimpleViewer in the OpenNI samples (doesn't this mean the drivers are installed?). I've read a few other posts regarding this, including

http://answers.ros.org/question/60766/kinect-not-recognized-with-opennilaunch/

and this

http://answers.ros.org/question/60562/ubuntu-12042-and-openni_launch-not-detecting-kinect-after-update/

but nothing works. I've also tried looking up the Asus drivers download page here

http://support.asus.com/Download.aspx?SLanguage=en&m=Xtion+PRO+LIVE&p=19&s=11

and noticed that it's quite outdated (OpenNI v1.5 and NiTE v.1.5, when v2.2 is out). I already have OpenNI v2.2 installed. Should I be installing NiTE 2.2? I ask because it's categorized as a Middleware Library.

Thanks!

edit retag flag offensive close merge delete

Comments

I see a problem like you, have you solved it successfully?

domikilo gravatar imagedomikilo ( 2013-11-25 17:17:18 -0500 )edit

Yes, the problem was that I installed the primesense drivers for v1.5, but my OpenNI version was v2.2. I downloaded OpenNI v1.5 instead and it worked.

Andrew.A gravatar imageAndrew.A ( 2013-11-26 13:25:45 -0500 )edit

So how about 's the version of sensor driver?

domikilo gravatar imagedomikilo ( 2013-11-26 15:55:24 -0500 )edit

Do you use the Live USB installation or Debs ? I use USB Installation, I tested successfully ASUS XTION with NIViewer it can receive data from Xtion , but when I tested with openni.launch, I see it notice : [camera/depth/points-10] process has died [pid 12126, exit code 255, cmd /opt/ros/groovy/lib/nodelet/nodelet load depth_image_proc/point_cloud_xyz /camera_nodelet_manager --no-bond image_rect:=image_rect_raw __name:=points __log:=/home/turtlebot/.ros/log/134c8d7c-5714-11e3-8e6d-70f1a10ec189/camera-depth-points-10.log]. log file: /home/turtlebot/.ros/log/134c8d7c-5714-11e3-8e6d-70f1a10ec189/camera-depth-points-10*.log So what problem with me?

domikilo gravatar imagedomikilo ( 2013-11-26 20:57:29 -0500 )edit

I updated my answer below, please check it. To fix your error, get the older version of openni_camera from source.

Andrew.A gravatar imageAndrew.A ( 2013-11-26 21:33:02 -0500 )edit

I run the sample code follower successfull bu using openni2_launch and openni2_camera

domikilo gravatar imagedomikilo ( 2013-12-03 17:29:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-11-26 13:29:40 -0500

Andrew.A gravatar image

updated 2017-04-24 01:58:30 -0500

130s gravatar image

The problem was that I installed the Primesense drivers for v1.5, but my OpenNI version was v2.2. I downloaded OpenNI v1.5 from here instead and it worked.

EDIT: Also, there is an issue with the openni_camera package. You can leave the deb package installed, as long as your compiled sources have priority. Use echo $ROS_PACKAGE_PATH and see if your source directory is first. This is what I have:

$ echo $ROS_PACKAGE_PATH
/home/andrew/catkin_ws/src:/opt/ros/groovy/share:/opt/ros/groovy/stacks

Go to your sources directory, get the source code using git and use the rollback_usb branch.

cd ~/catkin_ws/src
git clone https://github.com/ros-drivers/openni_camera.git
git checkout rollback_usb

Compile using catkin_make in the root of your catkin directory

cd ~/catkin_ws
catkin_make

Finally, test it out with roslaunch openni_launch openni.launch.

You can read more about this issue here.

Primesense drivers can be downloaded from the OpenNI website. I'm using v5.1.2.1 from here (32-bit). 64-bit version is here. I think there are more recent versions over here if you like, but I haven't tried them.

Alternatively, if you choose to use v2.2, then you should install the packages openni2_camera and openni2_launch instead (see here).

edit flag offensive delete link more

Comments

hi Andrew. A, I also have the same problem with your post. And I'm trying to solve it shown here http://stackoverflow.com/questions/22419932/kinect-openni-ubuntu-12-10-installed-by-apt-get. Could you give me some advices? Thank you

roskidos gravatar imageroskidos ( 2014-03-14 19:52:37 -0500 )edit
1

answered 2013-08-01 16:46:22 -0500

lifelonglearner gravatar image

This problem which appears while running

roslaunch openni_launch openni.launch

Can have following two reasons as I know ....

  1. Kinect power supply is not connected properly (LED at kinect may be blinking but kinect not getting power supply of 12V DC for operation which comes either from 12V AC to DC adapter or from robot base). This is the problem which normally happens. Please check the power supply.

  2. The USB of Kinect is not detected by the notebook. This is something that rarely happens.

edit flag offensive delete link more

Comments

I'm not using a Kinect, but an Asus Xtion Pro Live. Also, I'm not sure why power supply is not connected properly, because as I mentioned, I can run the OpenNI sample Simpleviewer. If the device isn't detected (which I think is the case), what can I do to solve this problem?

Andrew.A gravatar imageAndrew.A ( 2013-08-01 16:51:58 -0500 )edit

I think power connection to device and device connection to the notebook are two main problem when openni replies.
[ INFO] [1375408552.874803204]: No devices connected.... waiting for devices to be connected.
I have not worked on Asus Xtion Pro Live. so can not tell exactly.

lifelonglearner gravatar imagelifelonglearner ( 2013-08-01 17:08:17 -0500 )edit

Make sure that you haven't plugged your camera in a USB 3.0 port. I advise not plugging it into a USB hub either - doing so caused me problems at some point. I suppose that you checked this already, but better be safe.

Zayin gravatar imageZayin ( 2013-08-02 10:06:27 -0500 )edit

Zayin, I've plugged my device in a USB 2.0 port, and it still doesn't detect. Also, apparently in OpenNI v2, there is no need for Primesense sensor drivers (http://community.openni.org/openni/topics/compatibility_issues_with_xbox_kinect_with_openni_2_on_win_7_64_bit (see comments below)).

Andrew.A gravatar imageAndrew.A ( 2013-08-04 18:57:26 -0500 )edit

Do you think your problem could be related to this? http://answers.ros.org/question/63903/turtlebot-failed-to-open-port-devttyusb0/ Your error message is totally different, but I'm the type to try anything. Btw, unlike the Kinect, the Xtion is powered by USB directly, so I doubt power is the issue.

Zayin gravatar imageZayin ( 2013-08-06 06:53:18 -0500 )edit

I don't have the Xtion and its laptop with me currently, but tomorrow I'll check what version of Openni I'm using (I'm not the one who installed it so I don't know). [Edit] I do have libopenni2-0. Then, there must be a way of making it work for you too. I'm using Fuerte and Ubuntu 12.04, though.

Zayin gravatar imageZayin ( 2013-08-06 06:57:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-08-01 16:19:24 -0500

Seen: 10,776 times

Last updated: Apr 24 '17