rosws makes ROS_ROOT disappear in Groovy [closed]

asked 2013-07-25 03:46:01 -0600

Flavian gravatar image

updated 2013-07-25 03:46:27 -0600

A very basic problem:

  • I installed ROS Groovy, added /opt/ros/groovy/setup.bash to my .bashrc file
  • Then I created a ros_workspace dir in ~/ (mkdir, cd, rosws init, source setup.bash).
  • I noticed that ROS_ROOT was gone from my environment variables after sourcing my workspace (not before). I don't have this problem in Fuerte. My packages that were in my ros workspace won't compile now, even if I manually do "export ROS_ROOT=/opt/ros/groovy".

Why is that?

PS: I can't use catkin with my previous packages, and I want to use some features that are not in Fuerte.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-11-30 10:32:21.964834