Ask Your Question
0

Kinect not getting power from Irobot create base?

asked 2013-07-22 14:40:49 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am having problem while connecting the kinect power using DB25 connector of Irobot create base. The connector circuit is designed by clearpath robotics to provide 12V DC power to kinect by taking power from pin 10 and 14 of DB25 connector of irobot create base.

I read to a tutorial by Prof. Jason O'Kane he says that : For the Kinect sensor to operate correctly, it must draw power from the Create’s battery. (The 5V available from the USB connection to the netbook is not sufficient; the Kinect needs at least 8V. Note that seeing blinking lights in the Kinect is, in my experience, not enough to know for sure that the Kinect is receiving the power it needs.) Your Turtlebot has a cable connecting the Kinect to the Create for this purpose, but by default that power supply is disabled. To enable it .........

rosrun create_node kinect_breaker_enabler.py

I tried it but this is not working. The create base is connected to ttyACM0 port as the serial to USB connector definition.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-07-30 18:17:15 -0500

Hey If you are using Kinect with turtlebot then you have to move the bot to start kinect. If you move it couple of inches then you'll start receiving data from kinect.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-22 14:40:49 -0500

Seen: 175 times

Last updated: Jul 30 '13