decompression of registered depth gives weird duplicated depth image [closed]

asked 2013-07-20 12:57:17 -0500

jstraub gravatar image

updated 2016-10-24 08:35:11 -0500

ngrennan gravatar image

I am recording from a kinect using:

roslaunch turtlebot_bringup 3dsensor.launch; 
rosbag record -O rosbagtest /camera/rgb/image_color/compressed /camera/depth_registered/image_raw/compressed

then afterwards to replay I do:

rosbag  play -l rosbagtest.bag; 
rosrun image_transport republish compressed in:=/camera/depth_registered/image_raw/ raw out:=/camera/depth_registered/image_raw; 
rosrun image_transport republish compressed in:=/camera/rgb/image_color raw out:=/camera/rgb/image_raw;

This gives me a weird depth image that somehow seems to be duplicated and the depths are wrong as well (too far away):

depth image

RGB image

When I run the same program for displaying the depth and rgb stream directly without record and replay everything looks fine.

I am using groovy on a 12.04 linux. Does anyone have a clue whats going on here? Is the compression/decompression of depth images not yet stable in groovy?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-04-27 01:45:48.922822


Yes, I have the same problem! I think we forgot to change the compression from jpg to png, as jpg can't handle 16bit images. Also there is not only the duplicate problem, the depth image also looks like a binary image.. See my problem here:

madmax gravatar image madmax  ( 2013-07-28 05:14:32 -0500 )edit

Thanks for the reply - reading this I did: "rosparam set /camera/depth_registered/image_raw/compressed/format png" before recording the rosbag and then once I am replaying it. But the decompressed depth image still looks duplicated and binary.

jstraub gravatar image jstraub  ( 2013-07-30 05:32:23 -0500 )edit

Hmm, thought that was the problem. Would be interesting to know how this error can occur,

madmax gravatar image madmax  ( 2013-07-31 10:53:20 -0500 )edit