Ask Your Question
1

ueye ros driver not working properly

asked 2013-07-11 22:55:43 -0500

morera3 gravatar image

Hi,

I have a ueye IDS camera, model 1220LE-C, and I have tried the following ueye driver:

ros.org/wiki/ueye

With this driver, after a number of frames the camera pauses, but continues after 2 or 3 seconds. To check if it was a hardware or software compatibility problem I used the following ROS driver, without experimenting any problems:

ros.org/wiki/ueyecamera

So it seems to be a ROS driver problem with my camera model. Has anyone experimented the same behaviour with the first driver?

PD: running ROS fuerte, on Ubuntu 12.04 64 bits and IDS driver version 4.20_64_Bit.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-10-31 19:01:49 -0500

130s gravatar image

I've seen kind of similar issue (with UI155xSE-C) and ended up getting success by replacing mother board (, which was causing many other issues as well anyway). In addition, changing zoom size in cfg (and build the package) worked for us to get smooth images too. HTH.

edit flag offensive delete link more
1

answered 2013-11-03 23:41:25 -0500

morera3 gravatar image

As suggested by the user, I tested the driver in another board and it worked. It seemed to be related with the graphic card adapter.

The problems appeared using an HP ProBook 4540s, which has a HD Graphics 3000 graphic adapter. In other computers with distinct graphic adapter there are no problems and all works ok.

edit flag offensive delete link more
1

answered 2014-09-16 20:28:04 -0500

z3391384 gravatar image

I had the same issue. Yeah, I think it is the driver not compatible with the camera model. I used the old "ueyecamera" driver instead of the "ueye" driver, and now it is working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-11 22:55:43 -0500

Seen: 728 times

Last updated: Sep 16 '14