Error compiling in Arduino [closed]

asked 2013-07-10 22:37:45 -0500

sirgrussu gravatar image

Hello, I started using Arduino about half an year ago and it worked fine. Not too long ago, I ran into a random problem. I made a code and tried to compile it but I got an error saying, "Error Compiling" and no specific description. I thought it was my code so I went under the basic examples and tried a few of the examples but I still got the same error. I went under the preferences and selected the check mark called "compilation". That is I wanted to show verbose output during compilation and I got the following writing:

C:\Users\Sergei\Documents\Arduino\hardware\tools\avr\bin\avr-g++ -c -g -Os -Wall -fno-exceptions -ffunction-sections -fdata-sections -mmcu=atmega328p -DF_CPU=16000000L -MMD -DUSB_VID=null -DUSB_PID=null -DARDUINO=105 -IC:\Users\Sergei\Documents\Arduino\hardware\arduino\cores\arduino -IC:\Users\Sergei\Documents\Arduino\hardware\arduino\variants\standard C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\Blink.cpp -o C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\Blink.cpp.o Using previously compiled: C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\malloc.c.o Using previously compiled: C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\realloc.c.o Using previously compiled: C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\WInterrupts.c.o Using previously compiled: C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\wiring.c.o Using previously compiled: C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\wiring_analog.c.o C:\Users\Sergei\Documents\Arduino\hardware\tools\avr\bin\avr-gcc -c -g -Os -Wall -ffunction-sections -fdata-sections -mmcu=atmega328p -DF_CPU=16000000L -MMD -DUSB_VID=null -DUSB_PID=null -DARDUINO=105 -IC:\Users\Sergei\Documents\Arduino\hardware\arduino\cores\arduino -IC:\Users\Sergei\Documents\Arduino\hardware\arduino\variants\standard C:\Users\Sergei\Documents\Arduino\hardware\arduino\cores\arduino\wiring_digital.c -o C:\Users\Sergei\AppData\Local\Temp\build8735673440912437957.tmp\wiring_digital.c.o

I re-installed it a few times and it still does the same thing. I really need it to work but I dont know what to do. Please help if possible.

Sergei

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by Lorenzo Riano
close date 2013-07-11 11:45:28