Ask Your Question
1

ROS Installation on Fedora 19

asked 2013-07-08 15:23:53 -0500

atp gravatar image

updated 2013-07-23 06:27:29 -0500

I'm trying to install ROS Groovy on Fedora 19, following the instructions at wiki/groovy/Installation/Fedora. However, running the line

$ rosdep install --from-paths src --ignore-src --rosdistro groovy -y

results in the following error:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: pcl: No definition of [libusb-1.0-dev] for OS version [schrödinger’s]

locate libusb- gives:

/usr/lib/libusb-0.1.so.4 /usr/lib/libusb-0.1.so.4.4.4 /usr/lib/libusb-1.0.so.0 /usr/lib/libusb-1.0.so.0.1.0 /usr/lib64/libusb-0.1.so.4 /usr/lib64/libusb-0.1.so.4.4.4 /usr/lib64/libusb-1.0.so.0 /usr/lib64/libusb-1.0.so.0.1.0

The problem was how to get the letter 'ö' readable in the yaml file because rosdep resolve is giving this error: ERROR: No definition of [libusb-1.0-dev] for OS version [schrödinger’s]. I solved this by changing the OS name in /etc/system-release to schrodinger and then editing the yaml file.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2013-07-09 06:24:10 -0500

tfoote gravatar image

You need to add rosdep rules for Fedora 19. It's correctly detecting the OS correctly but the latest definition for libusb-1.0 is for spherical. https://github.com/ros/rosdistro/blob/master/rosdep/base.yaml

How to submit changes is documented here: http://ros.org/doc/independent/api/rosdep/html/contributing_rules.html

edit flag offensive delete link more

Comments

You say that this doesn't work for you. What did you do to try it? What errors did you get?

tfoote gravatar image tfoote  ( 2013-07-23 05:43:14 -0500 )edit

see above. basically, how can I get the 'ö' readable in the yaml file?

atp gravatar image atp  ( 2013-07-23 05:58:14 -0500 )edit

For the record, this is fixed in the latest release of rospkg: https://github.com/ros-infrastructure/rospkg/pull/54

cottsay gravatar image cottsay  ( 2014-05-10 20:57:35 -0500 )edit
-1

answered 2013-07-09 01:00:16 -0500

130s gravatar image

My guess is that Fedora 19 doesn't fall into how rosdep (or more precisely rospkg that's used inside) detects OS.

I would suggest to wait for answers from others but if there's not, then open an enhancement ticket here. I think that this Fedora class might need tweaked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-08 15:23:53 -0500

Seen: 482 times

Last updated: Jul 23 '13