Ask Your Question
1

ROS installation failed

asked 2013-07-08 03:25:25 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi !

I am trying to install ROS on a laptop in order to get it working with the Turtlebot2. I tried to install kobuki's packages thanks to this tutorial : http://www.ros.org/wiki/kobuki/Tutorials/Installation ; but something seems to have failed. First, I couldn't do this step :

roscd kobuki_ftdi 
make udev

The computer answered :

make: *** No rule to make target `udev'.  Stop.

And I might say that I am not really sure about what this step of the installation is for.

Then, if I tried to launch any launch file or script,

roslaunch kobuki_node minimal.launch

the computer answered that the package doesn't exist :

[kobuki_node] is not a package or launch file name

Although I did follow all the previous step with success (except the udev one).

As you suggested, I also tried http://www.ros.org/wiki/turtlebot/Tutorials/groovy/Installation I ran :

. /opt/ros/groovy/setup.bash
rosrun kobuki_ftdi create_udev_rules

and got this answer :

This script copies a udev rule to /etc to facilitate bringing
up the kobuki usb connection as /dev/kobuki.

[sudo] password for turtlebot: 

Restarting udev

udev stop/waiting
udev start/running, process 4208

But whenever I try to roslaunch a kobuki_package I still got the same error as above (and I need the auto_docking package). If I try to run a turtlebot's package,

roslaunch turtlebot_bringup minimal.launch

I got this error :

WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
WARNING: disk usage in log directory [/home/turtlebot/.ros/log] is over 1GB.
It's recommended that you use the 'rosclean' command.

Cannot locate [roslaunch]Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion roslaunch] returned with code [1]. 

Param xml is <param command="rosversion roslaunch" name="rosversion"/>

I don't know what went wrong and any hint about how to fix the situation is welcome.

edit retag flag offensive close merge delete

Comments

If you're following a tutorial, can you include a link to the one you're using? Also - copy&pasted error messages would be helpful.

lindzey gravatar image lindzey  ( 2013-07-08 05:24:31 -0500 )edit

I have the same problem, then when i try to roslaunch kobuki_node minimal.launch, my dashboard said Kobuki: Device does not exist. Waiting...

airizarry8 gravatar image airizarry8  ( 2013-07-08 09:55:21 -0500 )edit

It might be a different problem than mine. It seems like your packages are correctly installed. Are you sure your bot is plugged to the computer and powered ?

Lucile gravatar image Lucile  ( 2013-07-08 22:56:33 -0500 )edit

What happens when you start a roscore, talker, and listener?

lindzey gravatar image lindzey  ( 2013-07-09 04:30:48 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-07-09 04:52:28 -0500

Lucile gravatar image

I finally solved my problem. Here is what worked for me :

  1. I uninstalled everything linked to ROS (with purge option), deleted opt and etc ros folders
  2. I followed this tutorial : http://www.ros.org/wiki/groovy/Installation/Ubuntu until 1.5 Initialize rosdep step.
  3. To install rosdep, I used this command line :

    sudo pip install -U rosdep

That I found in this tutorial : http://www.ros.org/wiki/rosdep and checked that rosdep version was ok with this command line :

rosdep --version

(it has to be at least 0.10.19 version)

  1. And then I followed 1.5 Initialize rosdep and following steps from the first quoted tutorial

And everything was working fine after that.

edit flag offensive delete link more

Comments

Why exactly do you used the pip version of rosdep and not the debian package python-rosdep? Or, does it make a difference? The debian version says it's 0.10.21

felix k gravatar image felix k  ( 2013-07-10 03:49:22 -0500 )edit

Well, it didn't work for me when I tried python-rosdep. I always ended up with 0.9.3 version when I used it. Even after I updated. I don't know why. There were three different instructions I could try, I tried them and this one was the only one which worked for me.

Lucile gravatar image Lucile  ( 2013-07-10 03:59:41 -0500 )edit
1

answered 2013-07-08 09:53:50 -0500

BlitherPants gravatar image

updated 2013-07-08 09:59:47 -0500

Did you try running these two lines from the tutorial yet?

. /opt/ros/groovy/setup.bash
rosrun kobuki_ftdi create_udev_rules

When I installed my TurtleBot 2 I used the Turtlebot-specific line of tutorials (http://www.ros.org/wiki/turtlebot/Tutorials) rather than the Kobuki tutorials. Not sure which you've used, but the Turtlebot ones have worked for me.

Specific Tutorial: http://www.ros.org/wiki/turtlebot/Tutorials/groovy/Installation

edit flag offensive delete link more

Comments

yes i did, i used the same page

airizarry8 gravatar image airizarry8  ( 2013-07-08 10:02:57 -0500 )edit

On the Turtlebot tutorials, the bringup command is 'roslaunch turtlebot_bringup minimal.launch'. I don't remember ever needing to run 'kobuki_node minimal.launch'.

BlitherPants gravatar image BlitherPants  ( 2013-07-08 10:05:48 -0500 )edit

your absolutely right, is not in the turtlebot tutorials, but you can follow the kobuki tutorials, kobuki is the base platform of the turtlebot 2, by the way BlitherPants i think it was magic but now my turtlebot work, after the 101 time i evaluate that command

airizarry8 gravatar image airizarry8  ( 2013-07-08 10:22:45 -0500 )edit

Of course, but I'm a little confused. I thought you said you followed the same page? The page I posted is part of Turtlebot tutorials, not Kobuki tutorials. I have no idea if mixing directions from different tutorials will work. Just saying, following the Turtlebot tutorial solely does work.

BlitherPants gravatar image BlitherPants  ( 2013-07-08 10:32:31 -0500 )edit

Well I didn't follow that page, but the kobuki tutorial. But they linked a page with the command lines that you posted, and so I tried them. It didn't make anything work. I'll try to install Turtlebot's packages and will let you know.

Lucile gravatar image Lucile  ( 2013-07-08 22:21:55 -0500 )edit

I just updated the question after I tried to install Turtlebot's packages.

Lucile gravatar image Lucile  ( 2013-07-08 22:57:26 -0500 )edit

Weird; I never saw the error about logging or disk usage. I'm grasping at straws a little, but did you also run these lines (before the udev stuff) after installing ROS? 'sudo apt-get install ros-groovy-turtlebot ros-groovy-turtlebot-apps ros-groovy-turtlebot-viz '

BlitherPants gravatar image BlitherPants  ( 2013-07-09 03:27:13 -0500 )edit

I'm a newbie at this stuff myself, but I'm also curious why you're getting the disk error. Are you really low on space or something?

BlitherPants gravatar image BlitherPants  ( 2013-07-09 03:36:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-08 03:25:25 -0500

Seen: 1,038 times

Last updated: Jul 09 '13