Ask Your Question
0

rosdep fails with ResourceNotFound() [closed]

asked 2013-07-05 12:07:25 -0500

zoompig gravatar image

updated 2014-01-28 17:17:09 -0500

ngrennan gravatar image

Hi All,

I am new to ROS and working my way through the installation and startup tutorial on the wiki. I'm using Ubuntu 12.04.2 LTS

After installing groovy using apt-get, I run sudo rosdep init.

Then, I go to run rosdep update and get the following error:


kurt@sharceye1:~$ rosdep update

Traceback (most recent call last): File "/home/kurt/ros/ros/bin/rosdep", line 34, in <module> from ros import rosdep

File "/opt/ros/groovy/lib/python2.7/dist-packages/ros/__init__.py", line 54, in __getattr__ roslib.load_manifest(name.split('.')[0])

File "/opt/ros/groovy/lib/python2.7/dist-packages/roslib/launcher.py", line 62, in load_manifest sys.path = _generate_python_path(package_name, _rospack) + sys.path

File "/opt/ros/groovy/lib/python2.7/dist-packages/roslib/launcher.py", line 93, in _generate_python_path m = rospack.get_manifest(pkg)

File "/usr/lib/pymodules/python2.7/rospkg/rospack.py", line 136, in get_manifest return self._load_manifest(name)

File "/usr/lib/pymodules/python2.7/rospkg/rospack.py", line 175, in _load_manifest retval = self._manifests[name] = parse_manifest_file(self.get_path(name), self._manifest_name)

File "/usr/lib/pymodules/python2.7/rospkg/rospack.py", line 167, in get_path raise ResourceNotFound(name, ros_paths=self._ros_paths)

rospkg.common.ResourceNotFound: rosdep

ROS path [0]=/opt/ros/groovy/share/ros

ROS path [1]=/opt/ros/groovy/share

ROS path [2]=/opt/ros/groovy/stacks


The same error occurs even if I only do rosdep --version.

Using apt-get to re-install rosdep does not seem to help.

Trying to reinstall all of ROS (I think) like this:

sudo apt-get install --reinstall ros-groovy-desktop-full

does not resolve this.

Then, trying

sudo apt-get install --reinstall python-rospkg

doesn't seem to help either - I get the same error running rosdep.

Does anybody have a suggestion of what else I might try?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-28 16:21:45.339819

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-07-05 13:43:40 -0500

zoompig gravatar image

updated 2013-07-05 17:46:34 -0500

I got a little farther I think.

After uninstalling ros-groovy-desktop-full, I then do

aptitude purge ~c

apt-get autoremove

Then I reinstall ros-groovy-desktop-full. Now when I do

rosdep update

I get:

rosdep: error: Unsupported command update.

Any Ideas? Thanks!

edit flag offensive delete link more

Comments

1

For future reference, additional information about your problem should be added as an edit to your question, rather than added as an answer. This helps keep the Q&A format clearer. (I'm sorry - I don't know the answer to your question, and I'm using a different install than you)

lindzey gravatar image lindzey  ( 2013-07-07 20:17:11 -0500 )edit
0

answered 2013-07-07 20:23:20 -0500

130s gravatar image

There's a similar thread. Try the solution suggested there.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-05 12:07:25 -0500

Seen: 855 times

Last updated: Jul 07 '13