Ask Your Question
0

PointCloud2 orientation Problem? [I need some help!]

asked 2013-07-03 09:28:06 -0500

Gazer gravatar image

updated 2013-07-03 11:58:18 -0500

Hello All

I am having some problems with the orientation of ht PointCloud2 image published. I could tell it's not the problem with the TF because the axis looks correct according to the Rviz. Do you guys know where-else did I forgot to change the orientation? thank you in advance!


The problem is, as you could see from the image below. The TF transform is correct. But then the PointCloud2 looks like it has some "roll yaw pitch" error; the clouds should be on the ground plane; it shouldn't be flying at the mid air.

image descriptionimage descriptionimage description

edit retag flag offensive close merge delete

Comments

You didn't say what the problem was...

tbh gravatar image tbh  ( 2013-07-03 09:52:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-03 16:30:09 -0500

Gav gravatar image

Hi Gazer,

Just a guess, but I suspect your problem is actually due to the TF being wrong. Check out the REP here: http://www.ros.org/reps/rep-0103.html

For robots it's conventional to put the X+ as the 'forward' direction, but there's a lot of camera stuff that uses Z+ as the forward direction instead.

Cheers, Gavin

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-03 09:28:06 -0500

Seen: 233 times

Last updated: Jul 03 '13