Ask Your Question
0

communication problem with laptop and workstation - turtlebot

asked 2013-06-27 08:27:01 -0500

mickey11592 gravatar image

updated 2013-11-18 19:29:22 -0500

tfoote gravatar image

I am having a problem with my workstation communicating with the turtlebot netbook. from the netbook, I can run rviz or

rosrun image_view image_view image:=/camera/rgb/image_color

and I will receive an image. When I try the same from the workstation, I received no image. In rviz it says no images received, in image_view a small white windows opens. I believe I have set the ROS_MASTER_URI and the ROS_HOSTNAME correctly since I can publish from the workstation and subscribe from the laptop. I can not subscribe from the workstation though, it doesn't say the topic isn't being published, all that it does is end the line in the terminal and has a blinking cursor on a blank line. I ctrl C to stop the subscribing since nothing shows up. Also, when I run :

rqt -s kobuki_dashboard

or this:

roslaunch turtlebot_rviz_launchers view_robot.launch

From the turtlebot netbook, it runs perfectly fine. However, when I run it from the workstation the first one comes up but doesn't appear to be connected to the turtlebot. It says "Last message received 1372357558 seconds ago". When I run the second command (rviz) it comes up with just a create base. On the netbook It comes up correctly with the full turtlebot and kobuki base. Any help is appreciated and if more information is needed just ask. Thanks

Edit: Also, running rxgraph from the workstation shows that none of the nodes are connected (they are all red circles)

edit retag flag offensive close merge delete

Comments

1

Can you tell us how did you set ROS_MASTER_URI and the ROS_HOSTNAME on the workstation and on the laptop ? And have you synchronized workstation and laptop ? For this, you should use chrony: sudo ntpdate ntp.ubuntu.com or sudo ntpdate MasterIP. it may be the cause of "message received seconds ago"

jep31 gravatar image jep31  ( 2013-06-27 20:50:36 -0500 )edit

I have already synchronized the workstation and laptop but I just resynchronized them using sudo ntpdate http://ntp.ubuntu.com. The laptop ip is 192.168.1.4 the workstation ip is 192.168.1.3 on the workstation the ROS_MASTER_URI is http://192.168.1.4:11311 the ROS_HOSTNAME is 192.168.1.3. The latptop

mickey11592 gravatar image mickey11592  ( 2013-06-28 03:40:43 -0500 )edit

ROS_HOSTNAME is 192.168.1.4 and the ROS_MASTER_URI is http://localhost:11311. I did not set the ROS_MASTER_URI. I setup the laptop according to the directions in the tutorial (under robots, turtlebot, network setup for the Live USB Installation, and the workstation according to the directions also

mickey11592 gravatar image mickey11592  ( 2013-06-28 03:44:01 -0500 )edit

I believe explicitly setting the ROS_MASTER_URI on the turtlebot fixed my problem. Thank You!

mickey11592 gravatar image mickey11592  ( 2013-06-28 07:48:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-28 04:40:56 -0500

jep31 gravatar image

updated 2013-06-28 04:42:00 -0500

Your synchronization seems good and your IP configuration too. I cannot answer to your question, you should wait someone more experienced. I only can say you that for my part, I wrote explicitly ROS_MASTER_URI=http://192.168.1.4:11311 on Turtlebot and added ROS_IP=192.168.1.4.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-27 08:27:01 -0500

Seen: 958 times

Last updated: Jun 27 '13