Ask Your Question
2

Install Groovy from Source failed on sbcl

asked 2013-06-23 08:35:23 -0600

sgwhack gravatar image

updated 2016-10-24 09:02:36 -0600

ngrennan gravatar image

I am trying to install groovy from source on my Beaglebone Black, Ubuntu 12.10. After following the instructions, I execute:

rosdep install --from-paths src --ignore-src --rosdistro groovy -y

And then I get the error:

executing command [sudo apt-get install -y sbcl]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package sbcl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  sbcl-source sbcl-doc

E: Package 'sbcl' has no installation candidate
ERROR: the following rosdeps failed to install
  apt: command [sudo apt-get install -y sbcl] failed

It seems that sbcl is not available. Does anyone know how to get around this?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-09-01 12:38:49 -0600

andrew-unit gravatar image

If you would like to try removing things that use lisp, you can do that by removing the roslisp package, and by commenting out the run_depend dependency in the ros_comm package.

edit flag offensive delete link more

Comments

1

Could you explain precisely how to do this? I'm just getting started with ROS. Is the package to get rid of, in this case, just src/roslisp, and is the rundepend in src/ros_comm/package.xml?

JetForMe gravatar imageJetForMe ( 2013-11-10 19:54:55 -0600 )edit
1

worked perfectly! I only had to rm'd src/roslisp and then removed the reference to roslisp in src/ros_comm/ross_comm/package.xml.

Dereck gravatar imageDereck ( 2014-03-25 10:12:41 -0600 )edit
0

answered 2013-06-23 15:52:32 -0600

tfoote gravatar image

It sounds like sbcl is not available as a package in your distribution. You will probably want to remove anything that uses lisp from your workspace and try again.

edit flag offensive delete link more
0

answered 2013-07-01 09:51:36 -0600

I've the same error of Sgwhack, I've tried to manual install sbcl http://www.sbcl.org/getting.html, but I've error on start sbcl. It's possible to working around and manual install this missing packet?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-23 08:35:23 -0600

Seen: 468 times

Last updated: Sep 01 '13