Ask Your Question
1

Gazebo and MoveIt

asked 2013-06-18 05:12:00 -0500

knalj gravatar image

I'm following the last MoveIt quick start tutorial: moveit.ros.org/wiki/PR2/Gazebo/Quick_Start

When I run: roslaunch pr2_gazebo pr2_empty_world.launch

It outputs: [pr2_gazebo] is not a package or launch file name

I searched for it and I cannot find it. I followed all the previous tutorials, and they all worked. It wasn't until this one that I had issues.

I noticed that Gazebo is now "a stand alone project" has anyone resolved issues that may have come from this?

Also when I follow the command: roslaunch pr2_moveit_generated moveit_planning_execution.launch

The program launches, yet no model is shown.

It gives: Robot model not loaded, and: Planning scene not configured

Any help would be much appreciated

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-08 04:38:32 -0500

E1000ii gravatar image

I had the same problem, but using my custom robot. Found that 1.9/Using_roslaunch_Files_to_Spawn_Models helps to build and launch a model with last Gazebo version. So probably modifying the pr2 launch to match the tutorial guide will work.

It seems that I have not enought karma to post links. You will find all the info in Gazebos wiki, just look for this specific tutorial.

Any way, I was using grooby-destop-ull and I needed to uninstall ROS and install the grooby-desktop alone release. Add by hand some needed packages and install from source Gazebo and gazebo-ros-package. I followed Gazebo wiki instructions for that. If not, there was no way of get gazebo working from ros...

Now I get this error as you to: Robot model not loaded, and: Planning scene not configured

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-18 05:12:00 -0500

Seen: 464 times

Last updated: Jul 08 '13