Ask Your Question
6

RVIZ tutorial error ( dir 'include' is neither an absolute directory nor exists)

asked 2013-06-17 02:24:30 -0500

Asfandyar Ashraf Malik gravatar image

updated 2013-11-14 10:37:44 -0500

tfoote gravatar image

I am following the rviz tutorials on ROS wiki The basic shapes tutorial

Whenever I do the catkin_make in the folder I have made with the command

catkin_create_pkg using_markers roscpp visualization_msgs

it gives me the following error. What should I do?

 The specified base path "/home/asfandyar/using_markers" contains a CMakeLists.txt but "catkin_make" must be invoked in the root of workspace

I tried moving the CMakeLists.txt to the src folder and then I used catkin_make and it gave me the following error.

 CMake Error at /opt/ros/groovy/share/catkin/cmake/catkin_package.cmake:314 (message):
      catkin_package() include dir 'include' is neither an absolute directory nor
      exists relative to '/home/asfandyar/using_markers1/src'
    Call Stack (most recent call first):
      /opt/ros/groovy/share/catkin/cmake/catkin_package.cmake:98 (_catkin_package)
      CMakeLists.txt:50 (catkin_package)


    -- Configuring incomplete, errors occurred!
    Invoking "cmake" failed

What should I do?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-06-17 03:07:31 -0500

Asfandyar Ashraf Malik gravatar image

updated 2013-06-25 22:41:56 -0500

I figured it out. I moved the CMakeList.txt to the src file and I made an install folder there. This is a simple hack and I would not recommend this, but it worked for me.

edit flag offensive delete link more
0

answered 2019-08-22 04:25:59 -0500

ermanas gravatar image

Because you should create your package in your src folder.

More simply, after you create your catkin workspace, (Let's say catkin_ws) go to your src folder

cd /home/$USER/catkin_ws/src

Then create your package

catkin_create_pkg using_markers roscpp visualization_msgs

after that you need to do catkin_make in your catkin_ws.

cd /home/$USER/catkin_ws
catkin_make

Then go to the devel and run the setup.bash

 cd /home/$USER/catkin_ws/devel
 . setup.bash
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-17 02:24:30 -0500

Seen: 451 times

Last updated: Aug 22