Ask Your Question
0

unable to setup chroot environment

asked 2013-06-06 08:44:53 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi i am trying to install ROS in raspbian using source. I want to setup chroot enviornment. I have followed the steps given at ros installation instruction But when i run this command sudo cp /usr/bin/qemu-arm-static /mnt/usr/bin/

i get and error cp: cannot create regular file `/mnt/usr/bin/': No such file or directory.

Please help me!..i am not able to understand the steps to be followed so it may be the case that i am stuck for very silly reasons.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-06-11 02:43:18 -0500

jmueller gravatar image

updated 2013-06-11 02:43:36 -0500

Hey there, I just stumbled upon your question with some other issue, and am not a pro on this myself, but I would think that you did not mount your Pi's SD card to /mnt using

sudo mount /dev/sdc2 /mnt

or probably some other path, like "/dev/mmcblk0p2" instead of "/dev/sdc2" (which is what I am using). You can find which path it is by calling "sudo fdisk -l" once without the card inserted and once with it. Spot the difference ;)

Then try to copy again.

Also, if you just want to use ROS on the RPi, have a look at my attempt here: http://answers.ros.org/question/63705/problem-using-the-provided-groovy-rpi-image/#64027 (darn, I'm still not allowed to post links...)

edit flag offensive delete link more

Comments

Thank you!...yes i did the same and it is fixed now.

Bhargav gravatar image Bhargav  ( 2013-06-12 06:54:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-06 08:44:53 -0500

Seen: 91 times

Last updated: Jun 11 '13