Ask Your Question
0

porblem with kinect.launch file in turtlebot bringup

asked 2013-06-03 07:05:12 -0500

akhil gravatar image

updated 2016-10-24 08:35:04 -0500

ngrennan gravatar image

hi,

I want to run gmapping on turtlebot so i started with the basic turtlebot tutorials when i bringup the turtlebot and run the kincet.launch file the data published by kinect on /camera/depth/points is wrong also when i try to see the depth image using image view it's all black but when i run openni.launch file form the openni_launch package the kinect is publishing correct point cloud, ss there any problem with kinect.launch file in turtlebot_bringup I am using fuerte on ubuntu 12.04. this is my kinect.launch file

<launch> <node pkg="turtlebot_node" type="kinect_breaker_enabler.py" name="kinect_breaker_enabler"/>

<node pkg="nodelet" type="nodelet" name="pointcloud_throttle" args="load pointcloud_to_laserscan/CloudThrottle openni_manager" respawn="true"> <remap from="cloud_in" to="/camera/depth/points"/> <remap from="cloud_out" to="cloud_throttled"/> </node>

<node pkg="nodelet" type="nodelet" name="kinect_laser" args="load pointcloud_to_laserscan/CloudToScan openni_manager" respawn="true"> <remap from="cloud" to="/cloud_throttled"/> </node>

<node pkg="nodelet" type="nodelet" name="kinect_laser_narrow" args="load pointcloud_to_laserscan/CloudToScan openni_manager" respawn="true"> <remap from="cloud" to="/cloud_throttled"/> <remap from="scan" to="/narrow_scan"/> </node>

</launch>

akhil@ubuntu:~/fuerte_workspace/sandbox/turtlebot/turtlebot_bringup$ cat 2_kinect.launch <launch>

<node pkg="turtlebot_node" type="kinect_breaker_enabler.py" name="kinect_breaker_enabler"/>

<node pkg="nodelet" type="nodelet" name="openni_manager" output="screen" respawn="true" args="manager"/>

<node pkg="nodelet" type="nodelet" name="openni_launch" args="load openni_camera/OpenNINodelet openni_manager" respawn="true">

<rosparam command="load" />

</node>

<node pkg="nodelet" type="nodelet" name="pointcloud_throttle" args="load pointcloud_to_laserscan/CloudThrottle openni_manager" respawn="true"> <remap from="cloud_in" to="/camera/depth/points"/> <remap from="cloud_out" to="cloud_throttled"/> </node>

<node pkg="nodelet" type="nodelet" name="kinect_laser" args="load pointcloud_to_laserscan/CloudToScan openni_manager" respawn="true"> <remap from="cloud" to="/cloud_throttled"/> </node>

<node pkg="nodelet" type="nodelet" name="kinect_laser_narrow" args="load pointcloud_to_laserscan/CloudToScan openni_manager" respawn="true"> <remap from="cloud" to="/cloud_throttled"/> <remap from="scan" to="/narrow_scan"/> </node>

</launch>

edit retag flag offensive close merge delete

Comments

i just changed the value of <param depth_registration value="true" /> to false in kinect.laucnh file and it worked but i don't know if this is the right way to solve this problem, any suggestions ??

akhil gravatar image akhil  ( 2013-06-10 09:27:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-03 04:43:42 -0500

Lucile gravatar image

Settint this value to false means that you won't have registered value and so that depth informations and color informations might not have the same coordinates. Hope that helps (even thought my answer comes late)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-03 07:05:12 -0500

Seen: 573 times

Last updated: Jun 04 '13