ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Libpython2.7 build error, groovy [closed]

asked 2013-05-30 05:08:56 -0600

allenh1 gravatar image

Hello all,

Having an issue building some code that worked well in fuerte. As far as I can tell, it has been modified correctly. The compilation error comes from an inability to find

Anyone else have this problem (and perhaps a solution)?

allenh1@allenh1-Vostro-430:~/filter_ws/src/data_viewer$ rosmake
[ rosmake ] rosmake starting...                                                
[ rosmake ] No package specified.  Building ['data_viewer']                    
[ rosmake ] Packages requested are: ['data_viewer']                            
[ rosmake ] Logging to directory /home/allenh1/.ros/rosmake/rosmake_output-20130530-100530
[ rosmake ] Expanded args ['data_viewer'] to:
[rosmake-0] Starting >>> catkin [ make ]                                       
[rosmake-0] Finished <<< catkin ROS_NOBUILD in package catkin
 No Makefile in package catkin
[rosmake-0] Starting >>> genmsg [ make ]                                       
[rosmake-2] Starting >>> cpp_common [ make ]                                   
[rosmake-7] Starting >>> rospack [ make ]                                      
[rosmake-5] Starting >>> rosgraph [ make ]                                     
[rosmake-6] Starting >>> rosclean [ make ]                                     
[rosmake-4] Starting >>> angles [ make ]                                       
[rosmake-7] Finished <<< rospack ROS_NOBUILD in package rospack
 No Makefile in package rospack
[rosmake-2] Finished <<< cpp_common ROS_NOBUILD in package cpp_commonComplete ]
 No Makefile in package cpp_common
[rosmake-7] Starting >>> rostime [ make ]                                      
[rosmake-1] Starting >>> roslib [ make ]                                       
[rosmake-2] Starting >>> xmlrpcpp [ make ]                                     
[rosmake-6] Finished <<< rosclean ROS_NOBUILD in package rosclean
 No Makefile in package rosclean
[rosmake-5] Finished <<< rosgraph ROS_NOBUILD in package rosgraph
 No Makefile in package rosgraph
[rosmake-5] Starting >>> rosparam [ make ]                                     
[rosmake-0] Finished <<< genmsg ROS_NOBUILD in package genmsg
 No Makefile in package genmsg
[rosmake-7] Finished <<< rostime ROS_NOBUILD in package rostime
 No Makefile in package rostime
[rosmake-7] Starting >>> roscpp_traits [ make ]                                
[rosmake-3] Starting >>> genlisp [ make ]                                      
[rosmake-6] Starting >>> genpy [ make ]                                        
[rosmake-2] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp
 No Makefile in package xmlrpcpp
[rosmake-4] Finished <<< angles ROS_NOBUILD in package angles
 No Makefile in package angles
[rosmake-0] Starting >>> gencpp [ make ]                                       
[rosmake-1] Finished <<< roslib ROS_NOBUILD in package roslib
 No Makefile in package roslib
[rosmake-7] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits
 No Makefile in package roscpp_traits
[rosmake-5] Finished <<< rosparam ROS_NOBUILD in package rosparam
 No Makefile in package rosparam
[rosmake-5] Starting >>> roscpp_serialization [ make ]                         
[rosmake-4] Starting >>> roslang [ make ]                                      
[rosmake-6] Finished <<< genpy ROS_NOBUILD in package genpy
 No Makefile in package genpy
[rosmake-7] Starting >>> rosmaster [ make ]                                    
[rosmake-1] Starting >>> rosunit [ make ]                                      
[rosmake-3] Finished <<< genlisp ROS_NOBUILD in package genlisp
 No Makefile in package genlisp
[rosmake-0] Finished <<< gencpp ROS_NOBUILD in package gencpp
 No Makefile in package gencpp
[rosmake-5] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization
 No Makefile in package roscpp_serialization
[rosmake-5] Starting >>> message_runtime [ make ]                              
[rosmake-0] Starting >>> message_generation [ make ]                           
[rosmake-4] Finished <<< roslang ROS_NOBUILD in package roslang
 No Makefile in package roslang
[rosmake-1] Finished <<< rosunit ROS_NOBUILD in package rosunit
 No Makefile in package rosunit
[rosmake-1] Starting >>> rosconsole [ make ]                                   
[rosmake-0] Finished <<< message_generation ROS_NOBUILD in package message_generation
 No Makefile in package message_generation
[rosmake-5] Finished <<< message_runtime ROS_NOBUILD in package message_runtime
 No Makefile in package message_runtime
[rosmake-7] Finished <<< rosmaster ROS_NOBUILD in package rosmaster
 No Makefile in package rosmaster
[rosmake-7] Starting >>> std_msgs [ make ]                                     
[rosmake-5] Starting >>> rosbuild [ make ]                                     
[rosmake-1] Finished <<< rosconsole ROS_NOBUILD in package rosconsole
 No Makefile in package rosconsole
[rosmake-7] Finished <<< std_msgs ROS_NOBUILD in package std_msgs
 No Makefile in package std_msgs
[rosmake-5] Finished <<< rosbuild ROS_NOBUILD in package rosbuild
 No Makefile in package rosbuild
[rosmake-7] Starting >>> rosgraph_msgs [ make ]                                
[rosmake-5] Starting >>> qt_build [ make ]                                     
[rosmake-6] Starting >>> actionlib_msgs [ make ]                               
[rosmake-4] Starting >>> geometry_msgs [ make ]                                
[rosmake-7] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs
 No Makefile in package rosgraph_msgs
[rosmake-5] Finished <<< qt_build ROS_NOBUILD in package qt_build              
[rosmake-4 ...
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by allenh1
close date 2013-05-31 03:41:31

1 Answer

Sort by ยป oldest newest most voted

answered 2013-05-30 05:29:20 -0600

allenh1 gravatar image

Ok. Fixed it.

Do this:

sudo ln -sf /usr/lib/x86_64-linux-gnu/ /usr/lib/

Note: I am running Ubuntu 13.04. This might not be an issue on previous version of Ubuntu. This fix did work, and the program runs. I am using Groovy.

edit flag offensive delete link more

Question Tools


Asked: 2013-05-30 05:08:56 -0600

Seen: 174 times

Last updated: May 30 '13