Ask Your Question
1

rosjava installation

asked 2013-05-27 23:08:58 -0500

Jhansi gravatar image

Iam trying to install rosjava with following steps.

mkdir ~/my_workspace cd ~/my_workspace rosws init rosws merge /opt/ros/groovy/.rosinstall rosws set --git --version=groovy-devel rosjava_core 'git://github.com/rosjava/rosjava_core.git' rosws update source setup.bash

Everything seems to be working fine until I run the rosws update command.It gives the error as following.

[rosjava_core] Updating /home/jhansi/my_workspace/rosjava_core WARNING [vcstools] Command failed: 'git fetch' run at: '/home/jhansi/my_workspace/rosjava_core' errcode: 128: error: RPC failed; result=56, HTTP code = 200 fatal: The remote end hung up unexpectedly fatal: early EOF fatal: index-pack failed warning: http unexpectedly said: '0000' [/vcstools] Exception caught during install: Error processing 'rosjava_core' : [rosjava_core] Update Failed of /home/jhansi/my_workspace/rosjava_core

ERROR in config: Error processing 'rosjava_core' : [rosjava_core] Update Failed of /home/jhansi/my_workspace/rosjava_core

edit retag flag offensive close merge delete

Comments

Are you installing for ROS groovy?

HenryW gravatar image HenryW  ( 2013-05-28 11:58:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-28 12:05:03 -0500

HenryW gravatar image

Hey,

First do not use rosws, that was what I was told. Install from source and run catkin_make.

ROSjava has been catkinized. Basically what I did to install was to download into my work space from source https://github.com/rosjava/rosjava_core

cd into my work_space and run "catkin_make". It then nicely compile everything for me. I did run into an error at one point but it has been resolved here https://github.com/rosjava/rosjava_core/issues/156

If catkin_make does not work, you can cd into ROSjava package and just run ./gradlew as well. Or at least I could about a month ago.

Hope that helps :D

edit flag offensive delete link more

Comments

other potential bugs when it does start compiling for you, usually solved by setting JAVA_HOME, I ran into the same problem as this link and the second answer solved the issue for me

http://answers.ros.org/question/31800/building-rosjava-fails-at-task-apache_xmlrpc_commoncompilejava/

HenryW gravatar image HenryW  ( 2013-05-28 12:07:07 -0500 )edit

It gives the error as: What went wrong: Could not resolve all dependencies for configuration ':rosjava_test:compile'. > Could not resolve junit:junit:4.8.2.

Jhansi gravatar image Jhansi  ( 2013-05-29 21:21:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-27 23:08:58 -0500

Seen: 329 times

Last updated: May 28 '13