Ask Your Question
0

Cannot use ps3joy with turtlesim (can't locate node [ps3_joy_node])

asked 2013-05-17 14:29:11 -0500

Pedro_85 gravatar image

updated 2013-05-22 05:09:16 -0500

Hi everyone,

I am new to ROS. I was following the on using a ps3 controller to operate turtlesim but unfortunately I have encountered the following error after I use "roslaunch learning_ps3joy turtle_ps3joy.launch":

ERROR: cannot launch node of type [ps3joy/ps3_joy_node]: can't locate node [ps3_joy_node] in package [ps3joy]

I can see the turtlesim window with its turtle in it. I completed the tutorial to configure a ps3 controller and I was able to see it work with no errors.

Any ideas on why this is happening?

Edit 1:

I have a feeling the problem is in the launch file when executing the ps3joy node. Here is the code as it is shown in the tutorial:

<node respawn="true" pkg="ps3joy" type="ps3_joy_node" name="PS3_turtle_joy" >="" <param="" name="dev" type="string" value="/dev/input/js2"/> </node>

Edit 2: One thing that I have noticed is when I run roscd joy or roscd ps3joy the directory lies in /opt/ros/groovy/share/joy and /opt/ros/groovy/share/ps3joy. I have found the joy_node file in /opt/ros/groovy/lib/joy and the ps3joy_node.py in /opt/ros/groovy/lib/ps3joy directories.

Under the /opt/ros/groovy/share/joy directory all I see are: cmake migration_rules package.xml

And for /opt/ros/groovy/share/ps3joy cmake diagnostics.yaml launch package.xml

edit retag flag offensive close merge delete

Comments

Which ROS version are you using?

felix k gravatar image felix k  ( 2013-05-22 01:17:25 -0500 )edit

Groovy, sorry for not including that.

Pedro_85 gravatar image Pedro_85  ( 2013-05-22 02:51:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-21 03:42:32 -0500

felix k gravatar image

updated 2013-05-22 03:47:18 -0500

The fuerte version of ps3_joy_node had already been a redirection to joy_node of package joy, naming its own use deprecated.

Apparently this was fully removed with groovy.

Please edit every launch file and tutorial you see with a call to joy_node ps3_joy_node into joy joy_node so this antiquity gets eliminated.

edit flag offensive delete link more

Comments

I have run rosmake ps3joy and it reported no errors. As I said before I was able to use the ps3joy package to receive information from my ps3 controller. I have a feeling that the problem lies in the launch file commands. I have pasted the code in the question.

Pedro_85 gravatar image Pedro_85  ( 2013-05-21 04:48:50 -0500 )edit

It didn't work either. The result was similar but with joy instead of ps3joy. I have edited the question with more details I have found.

Pedro_85 gravatar image Pedro_85  ( 2013-05-22 05:04:09 -0500 )edit
1

Now it's working. In addition to your suggestion, I modified the manifest file adding sensor_msgs to the dependencies. Then I ran rosrun ps3joy ps3joy_node.py and in a different terminal launched the learning_ps3joy. Thanks for your help.

Pedro_85 gravatar image Pedro_85  ( 2013-05-22 06:29:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-17 14:29:11 -0500

Seen: 988 times

Last updated: May 22 '13