Ask Your Question
1

Broken link to 'sbpl' planner package

asked 2013-05-08 13:15:08 -0500

mosfet2u gravatar image

updated 2013-05-09 05:16:29 -0500

I have been trying to install the 'sbpl_lattice_planner' package ...

in ROS Fuerte. It appears to need a package called 'sbpl' appears to be broken.

Attempts to get it from other sources also led nowhere!

Thanks!

MORE DETAILS ON WHAT I DID AS A RESPONSE TO JEREMY'S RESPONSE ... I was trying to follow the sbpl_lattice planner ROS wiki instructions for installation and execution. I did the following: a) acquired the "navigation _experimental" stack (for fuerte) b) tried to execute the following two suggested commands: rosmake sbpl_lattice_planner roslaunch sbpl_lattice_planner move_base_sbpf_fake_localization_2.5cm.launch c) the compilation did not complete because it pointed to a missing 'sbpl' package. After extensive search resulting in the discovery of several broken links (including Maxim Likhachev's site). d) after further search, found 'sbpl' as part of the "footsteps planner" package. Downloaded it and did a separate compilation and integration into the 'sbpl_lattice_planner'. e) I thought I had solved the problem until I ran the roslaunch command. This led to several errors due to inability to execute the required Python commands.

JEREMY: I will try what you suggested (apt-get install ros-fuerte-sbpl).

UPDATE: Just finished executing apt-get install ros-fuerte-sbpl. No luck ... details below ... 'rosmake sbpl_lattice_planner' command goes through without any errors. 'roslaunch sbpl_lattice_planner move_base_sbpf_fake_localization_2.5cm.launch' command fails with the message 'ResourceNotFound: sbpl'

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-08 17:50:10 -0500

I think sbpl is available as an Ubuntu package. Have you tried apt-get install ros-fuerte-sbpl? I see that the source-code link on the sbpl wiki page is broken. It looks to me like the current version of this package can be found on github instead.

What issues are you having, specifically?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-08 13:15:08 -0500

Seen: 316 times

Last updated: May 22 '13