Ask Your Question
0

Tf roslaunch issue, Package Path not set up properly?

asked 2013-04-30 10:04:44 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I've been trying to launch the learning_tf package from the tf tutorials, and seem unable to find it, no matter how much I change my env variables. The command is "roslaunch learning_tf start_demo.launch" but it's also failing on other commands.

The workspace I'm using is ~/catkin_ws/src I'm operating on groovy.

I'm convinced that the problem has to do with what I should set my ROS_PACKAGE_PATH to, but I don't know what it should be. I've tried several different options, and can normally locate things in /opt/ros/groovy/stacks, but not packages in catkin_ws.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-30 11:03:54 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

You should not set your ROS_PACKAGE_PATH. Source the setup.bash/setup.sh within the catkin workspace, usually at devel/setup.bash.

edit flag offensive delete link more

Comments

Thank You, this appears to have solved the issue

mlpayne1 gravatar image mlpayne1  ( 2013-05-01 08:36:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-30 10:04:44 -0500

Seen: 151 times

Last updated: Apr 30 '13