Ask Your Question
6

Problem with Xtion Pro Live and openni_camera

asked 2013-04-20 15:28:53 -0500

Gav gravatar image

Hi,

Had an interesting one recently where we purchased two new Asus 'XTION Pro Live' cameras, and had them fail to work in ROS. Posting and answering my own question here, since I don't want anyone else to have to go through the 2hrs of troubleshooting we did.

Bad device has serial 
32101 - 1302250110
and sticker 
D3IWBDA18501

Good device has serial
3210 -1206070413
and sticker
C6IWBDA07705

I ran 'lsusb' to find the usb details for this device, and 'meld' to compare them to the old one, and it seems they have different USB endpoints available, and also different USB device IDs. The new device is ID 0601, and the old device is 0600.

After looking around it seems that the udev rules are set correctly to expect this variant:

turtlebot@bert:/opt/ros/groovy/share/openni_camera$ cat /lib/udev/rules.d/40-libopenni-sensor-primesense0.rules 
# PrimeSense Devices
SUBSYSTEM=="usb", ATTR{idProduct}=="0200", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"
SUBSYSTEM=="usb", ATTR{idProduct}=="0300", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"
SUBSYSTEM=="usb", ATTR{idProduct}=="0400", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"
SUBSYSTEM=="usb", ATTR{idProduct}=="0500", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"
SUBSYSTEM=="usb", ATTR{idProduct}=="0600", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"
SUBSYSTEM=="usb", ATTR{idProduct}=="0601", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"

<snip...&gt;< p="">

Some other people had issues and suggested installing openni-sensor-primesense-bin or similar packages, (run 'sudo apt-get install openni-sensor-primesense-bin', and the latest one was 5.1.0.41, which people thought was necessary).

But that did not seem to help.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
10

answered 2013-04-20 15:31:34 -0500

Gav gravatar image

updated 2013-04-20 15:32:53 -0500

The solution we came up with was to edit the file: /etc/openni/Globaldefauts.ini (make a backup first)

find the line UsbInterface and uncomment it to force it to use 'BULK' endpoints: UsbInterface=2

No idea if this is correct, but it worked in our case on two machines. It also seems to make sense if you consider the different USB endpoint options between the two models.

Hope this helps!

edit flag offensive delete link more

Comments

Thank you very much!!, you save me a lot of debugging time! really appreciate it. don exactly what you say: installed the latest openni drivers. and edited the config file. all good now.

ezex gravatar image ezex  ( 2013-08-30 07:13:17 -0500 )edit
1

Be sure to reboot after you make the change. I didn't realize that and thought this didn't work at first but read it later (after a few days of troubleshooting) to find that it worked just fine.

hfb gravatar image hfb  ( 2014-04-14 09:07:26 -0500 )edit

Thanks Gav! It helped a lot.

karthik gravatar image karthik  ( 2014-09-20 12:33:08 -0500 )edit

Thanks you a lot for your answer, it worked for me too.

Swan Baigne gravatar image Swan Baigne  ( 2015-10-05 06:49:43 -0500 )edit

I'm launching two orbecc astra cameras with the same problem, and this solution fixed it for me too. Thanks!

buckley.toby gravatar image buckley.toby  ( 2017-11-01 14:49:17 -0500 )edit
0

answered 2013-11-25 01:52:39 -0500

erikb gravatar image

updated 2016-05-26 02:26:51 -0500

Procópio gravatar image

I have a similar problem, I cannot get the computer to recognize the Asus sensor. My file Globaldefauts.ini looks like this:

; USB interface to be used. 0 - FW Default, 1 - ISO endpoints, 2 - BULK endpoints. Default: Arm - 2, other platforms - 1 ; UsbInterface=2

Exactly how shall I change it?

edit flag offensive delete link more

Comments

Can you please explain how to apply the necessary changes or basically uncomment the line?

rdhn gravatar image rdhn  ( 2015-03-07 11:40:40 -0500 )edit
1

You just have to remove the ";" character before the UsbInterface=2 line

Swan Baigne gravatar image Swan Baigne  ( 2015-10-05 06:50:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-20 15:28:53 -0500

Seen: 9,142 times

Last updated: May 26 '16