Ask Your Question
1

How to install ROS-fuerte with the dependency to python 2.6 when python 2.7 also exists in Ubuntu12.04?

asked 2013-03-27 01:34:35 -0500

Amigoshan gravatar image

updated 2014-04-20 14:06:47 -0500

ngrennan gravatar image

My environment is Ubuntu-12.04, ROS-fuerte. The default python version on Ubuntu-12.04 is python-2.7. I firstly installed ROS-fuerte depending on python-2.7. But I would like to use ROS with other software that developed by Python-2.6. So I installed python-2.6, and make it default in my system. And then I re-installed the ROS-fuerte (want to change its dependency) using "sudo apt-get install ros-fuerte-desktop-full". But I found that the ROS still depends on python-2.7(the python library under ROS is /opt/ros/fuerte/lib/python2.7). What should I do to make ROS work with python-2.6?

edit retag flag offensive close merge delete

Comments

Interestingly, I just found that python version supported in fuerte is 2.6, which is not supported on Precise. I opened a question.

130s gravatar image 130s  ( 2013-04-18 12:44:07 -0500 )edit

Are you sure the other software will not work with Python 2.7? There are not many differences.

joq gravatar image joq  ( 2013-05-07 09:36:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-06 15:06:01 -0500

tfoote gravatar image

ROS will work with python 2.6, but the packaged binaries are packaged against the default system python. If you pull the packages you need from source they should work. Repackaging will be a very big pain.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-27 01:34:35 -0500

Seen: 287 times

Last updated: May 06 '13