Ask Your Question
0

sudo easy_install wstool rospkg rosdep

asked 2013-03-26 18:28:17 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

hello friends, When i run this command on Raspberry pi,i'm getting this messages on terminal

http://www.ros.org/wiki/groovy/Installation/Raspbian/Source (link text)

Message:

Searching for wstool Reading http://pypi.python.org/simple/wstool/ Download error on http://pypi.python.org/simple/wstool/: [Errno 111] Connection refused -- Some packages may not be found! Reading http://pypi.python.org/simple/wstool/ Download error on http://pypi.python.org/simple/wstool/: [Errno 111] Connection refused -- Some packages may not be found! Couldn't find index page for 'wstool' (maybe misspelled?) Scanning index of all packages (this may take a while) Reading http://pypi.python.org/simple/ Download error on http://pypi.python.org/simple/: [Errno 111] Connection refused -- Some packages may not be found! No local packages or download links found for wstool

error: Could not find suitable distribution for Requirement.parse('wstool')

Can you please suggest best way to comeback.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-26 19:03:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello,

Just run same command with ABC changes

sudo -E easy_install wstool rospkg rosdep

This will may work fine.

edit flag offensive delete link more

Comments

Thanks that looks like it works fine sudo -E easy_install virtualenv The -E switch preserves your current environment. Info

http://superuser.com/questions/258819/easy-install-will-not-connect-through-proxy

Srinivas gravatar image Srinivas  ( 2013-03-26 19:04:23 -0500 )edit
0

answered 2014-02-13 06:04:21 -0500

Did not work for me. This did though as root in my .bashrc file. user is a valid user that can go outside proxy, not 'root'.

export http_proxy="user@server:port" export https_proxy="user@server:port"

You need BOTH env variables.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-26 18:28:17 -0500

Seen: 1,010 times

Last updated: Feb 13 '14