Ask Your Question
1

catkin_make_isolated fails with "--install-space /opt/ros/groovy"

asked 2013-03-25 17:41:33 -0500

130s gravatar image

Environment) OSX 10.8.2, Groovy following this tutorial.

$ ./src/catkin/bin/catkin_make_isolated --install

seems to successfully build groovy desktop. This workaround for sip related error worked.

However the following fails. The solution for sip above doesn't make any difference.

$ sudo ./src/catkin/bin/catkin_make_isolated --install --install-space /opt/ros/groovy
:
ImportError: No module named sipconfig

Full error output.

What's wrong?

As a workaround I might be able to build first with 1st method then move the artifact to the different folder (under /opt in this case) but because script files generated by catkin contains absolute path it's cumbersome.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-03-25 19:30:28 -0500

William gravatar image

updated 2013-03-25 19:32:37 -0500

The problem is that most likely your 'sudo' environment does not have the sip module in its path. I bet if you do:

$ sudo bash
# ./src/catkin/bin/catkin_make_isolated --install --install-space /opt/ros/groovy

That it would work. Another solution would be to create the /opt/ros folder and then make it user writable therefore you will not have to use sudo every time:

$ sudo mkdir -p /opt/ros
$ sudo chmod a+w /opt/ros
$ ./src/catkin/bin/catkin_make_isolated --install --install-space /opt/ros/groovy

But honestly why install it to /opt/ros/groovy? Why not ~/groovy?

edit flag offensive delete link more

Comments

Thanks, now trying. /opt/ros I thought is recommended in wiki.

130s gravatar image 130s  ( 2013-03-25 20:32:23 -0500 )edit

There is a note here: http://www.ros.org/wiki/groovy/Installation/OSX/Homebrew/Source#groovy.2BAC8-Installation.2BAC8-Source.Building_the_catkin_Workspace but that just says if you "want to" the official lines don't tell you to do so. It is completely optional, there is no functional difference.

William gravatar image William  ( 2013-03-26 07:18:04 -0500 )edit

Makes sense. Actually there seems to be still other issue when I use sudo other than the issue I noted (in my case gencpp complains) so I just use non-sudo env.

130s gravatar image 130s  ( 2013-03-27 22:46:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-25 17:41:33 -0500

Seen: 1,758 times

Last updated: Mar 25 '13