Ask Your Question
0

Install Geometry stack from source

asked 2013-03-23 08:00:09 -0600

aman501 gravatar image

updated 2014-01-28 17:15:51 -0600

ngrennan gravatar image

I am on an embedded ARM system (Pandaboard) so I don't have the geometry stack installed by default - specifically tf at the moment. tf is a dependency on another package, but I can't for the life of me figure out how to get ros to recognize that I have it. I ran

hg clone https://kforge.ros.org/geometry/geometry

into my workspace and then ran rosws set geometry. However, still rospack list does not list tf as being installed. I haven't had to rosmake any of the other packages I've done like this, but nonetheless, I tried that and it failed. There are no manifest.xml files in the packages. Could that be why they aren't being recognized? How would I build those manifests if so? I also tried cloning it into my /opt/ros/fuerte/stacks/ directory. still no-go.

Sorry if there is something very basic that I'm missing, but I've been stumped for a few days now. Thanks so much ahead of time.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2013-03-23 11:23:31 -0600

jbohren gravatar image

updated 2013-03-23 11:29:21 -0600

The tip of the geometry stack has already been migrated to catkin. If you want to build it in ROS Groovy, you need to set up a catkin workspace. If you want to build the geometry stack from source in Fuerte, you'll need to use an older version like this one: https://kforge.ros.org/geometry/geometry/rev/cbfce76cb39f

Also, the geometry source has (very) recently been migrated to github: https://github.com/ros/geometry so it would be best to clone from https://github.com/ros/geometry/tree/fuerte_devel

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-23 08:00:09 -0600

Seen: 401 times

Last updated: Mar 23 '13