Ask Your Question
0

ROSSERIAL and Helloworld issue on arduino 2560

asked 2013-03-14 02:48:58 -0500

Sasha gravatar image

updated 2014-01-28 17:15:43 -0500

ngrennan gravatar image

Hi! I am quiet new to ubuntu and arduino. I managed to install arduino IDE, ROS and even ROSSERIAL. Now while compiling (uploading) the hello world example I have a lot of errors and I don't know how to fix them. Here I provided a printscreen of my IDE, terminal and also my home folders...maybe you can advise me something...

imageshack.us/photo/my-images/443/screenshotfrom201303141.png/

P.S: my system information Intel® Core™ i7-2630QM CPU @ 2.00GHz × 8 Ubuntu 12.04 LTS 64bit

Thank you in advance

edit retag flag offensive close merge delete

Comments

Did you load the example from the lib in the arduino interface? Looks like your library is not correctly installed..

davinci gravatar image davinci  ( 2013-03-14 03:59:51 -0500 )edit

Yes I used the example from ros_lib that I installed few hours ago. I took also a printscreen during my installation because I had an IOError (maybe that's why I have troubles). Any ideas how to fix it? http://imageshack.us/photo/my-images/268/screenshotfrom201303141.png/

Sasha gravatar image Sasha  ( 2013-03-14 04:08:41 -0500 )edit

Ok I figured out and fixed the problem thanks to my teacher! But there is definetly a bug with catkin and probably 64bits Ubuntu 12.04LTS. It would be nice if some developpers would find time to check it for the future...

Sasha gravatar image Sasha  ( 2013-03-14 07:20:45 -0500 )edit

Then please file a bug report (and also post your solution so that others can solve the problem also).

davinci gravatar image davinci  ( 2013-03-14 23:33:45 -0500 )edit

You need to edit your bashrc file by doing the next: gedit gedit ~/.bashrc
export ROS_PACKAGE_PATH=/home/alexander/catkin_ws/install/share:/home/alexander/catkin_ws/install/stacks:/home/alexander/catkin_ws:$ROS_PACKAGE_PATH

Sasha gravatar image Sasha  ( 2013-03-15 02:38:30 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-03-15 02:54:02 -0500

Sasha gravatar image

Solution (for ROS groovy and Ubuntu 12.04LTS 64bit):

You need to edit your bashrc file by doing the next in terminal: $gedit ~/.bashrc

After that you need to specify the path like this (just copy and paste somewhere inside):

export ROS_PACKAGE_PATH=/home/YOURNAME_PROBABLY/catkin_ws/install/share:/home/YOURNAME_PROBABLY/catkin_ws/install/stacks:/home/YOURNAME_PROBABLY/catkin_ws:$ROS_PACKAGE_PATH

Info: catkin_ws is the catkin workspace that you should have settled up during ROS installation

After that I had also the problem while running: rosrun rosserial_python serial_node.py /dev/ttyUSB0

That USB0 should be ACM0 (for arduino)

That was it in short!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-14 02:48:58 -0500

Seen: 158 times

Last updated: Mar 15 '13