Ask Your Question
0

robotis.launch trouble finding AX 12 dynamixel motors

asked 2013-03-12 04:27:08 -0600

Rizqa gravatar image

updated 2013-03-12 04:30:28 -0600

Hello...

I am trying to run pi_tracker.. But,when I use "roslaunch pi_tracker robotis.launch" I encounter none of the motors are detected..

I have tried to detected the motors using the dynamixel_motor package and can successfully detect and identify motors.

Currently I am connecting 3 motors(id 1, 6, 7). The usb2dynamixel is currently set to TTL..

How could this problem solved ?

Thank you...

Installed: ubuntu 11.10 x32 electric pi_tracker pyserial

dynamixel_motors:

[INFO] [WallTime: 1363075666.690905] Pinging motor IDs 1 through 25... [INFO] [WallTime: 1363075667.065507] Found motors with IDs: [1, 6, 7]. [INFO] [WallTime: 1363075667.225608] There are 3 AX-12+ servos connected [INFO] [WallTime: 1363075667.226162] Dynamixel Manager on port /dev/ttyUSB0 initialized

pi_tracker:

RuntimeError: lib_robotis: Error encountered. Could not find ID (1) on bus (/dev/ttyUSB0), or USB2Dynamixel 3-way switch in wrong position.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-12 17:15:47 -0600

Pi Robot gravatar image

updated 2013-03-13 03:17:44 -0600

Hi @Rizqa,

If you are using the current version of the robotis package from here, then it appears that it is no longer reading ROS parameters to set the baudrate and port. The defaults are 57600 for baudrate and /dev/ttyUSB0 for the port. You probably need to change the baudrate to 1000000 which you can do by editing the lib_robotis.py file:

$ roscd robotis/src/robotis

Then edit the file lib_robotis.py and change the baud rate to 1000000. This worked for me.

--patrick

edit flag offensive delete link more

Comments

Thanks.. it works fine.. :)

Rizqa gravatar imageRizqa ( 2013-03-12 20:19:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-12 04:27:08 -0600

Seen: 574 times

Last updated: Mar 13 '13