Ask Your Question
0

Workstation to Turtlebot PC help

asked 2013-03-10 10:30:04 -0500

smkybear15 gravatar image

Right now I am on turtlebot installation part 4 network config part 5.3

On my workstation PC when I type rostopic list I get the error "unable to communicate with master" The value of ROS_MASTER_URI I get the IP of the turtlebot PC is that correct? and what do I need to do to get my workstation to communicate with my turtlebot PC

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-10 10:39:01 -0500

Devasena Inupakutika gravatar image

Hi,

Yes, ROS_MASTER_URI is your turtlebot laptop ip address. You need to export ROS_HOSTNAME as well in both turtle bot laptop and your workstation laptop. i.e.

Append below statements in your .bashrc file -->

  1. For Turtle bot laptop:

export ROS_MASTER_URI=<turtle bot="" ip="" address="">:11311 export ROS_HOSTNAME=<turtle bot="" ip="" address="">

  1. For Workstation laptop:

export ROS_MASTER_URI=<turtle bot="" ip="" address="">:11311 export ROS_HOSTNAME=<turtle bot="" ip="" address="">

  1. Now try pinging one from another.

  2. Run roscore in one and do rostopic list then.

  3. rostopic /echo diagnostics in another one.

It should work. Hope this helps !!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-10 10:30:04 -0500

Seen: 224 times

Last updated: Mar 10 '13