Ask Your Question
0

Problems running the ccny_rgbd package

asked 2013-03-10 03:08:03 -0500

jd gravatar image

I'm trying to get ccny_rgbd working on a turtlebot. It seems to be kind of working but I think it's still not quite working as it should.

On the turtlebot I launch:

roslaunch ccny_openni_launch openni.launch publish_cloud:=true

I get a complaint in the terminal about a missing camera calibration file but it still seems to run anyway.

Then on the workstation I launch:

roslaunch ccny_rgbd vo+mapping.launch

I run the corresponding rViz config file. At this point I did get a rgbd image in rViz but it takes a very long time, several minutes. I left it running for a while and it did update the rgbd image but the update rate was very slow. Again several minutes per image. Other times it doesn't give me the rgbd image at all after waiting up to 10min. I'm sure this isn't normal but I'm not really sure where to ever start at trying to fix it. Maybe my computer is just too slow for this?

I also tried to record a bag file to try and process the data later but ran into a problem with the TF data being old. Not sure what's going on there either. It seems to run fine when I'm not trying to record the bag file.

edit retag flag offensive close merge delete

Comments

1

Can you post information about your setup? What's your processor? Is anything running over a wifi network?

Ivan Dryanovski gravatar image Ivan Dryanovski  ( 2013-03-10 05:55:40 -0500 )edit

The turtlebot has a dual intel atom 1.86Ghz processor. The workstation I'm worried about. It's an acer laptop with an AMD triple core at 2.1Ghz. I've tried it on two networks both seem to give the same result. I do have an unused router that I could use to set up a network just for turtlebot.

jd gravatar image jd  ( 2013-03-10 08:31:03 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-03-13 05:32:32 -0500

The turtlebot processor might be a little slow for the VO. Try it with QVGA data. Post the output of your console here, and I will try to help you further.

Alternatively, you can try streaming the data out of the turltebot and runing the VO on the laptop. You might run into network issues, so again, setting to QVGA is recommended to reduce the bandwidth.

edit flag offensive delete link more

Comments

Thanks. I actually was testing it again today before I saw your comment so I don't have any output right now. I connected the workstation and turtlebot directly to my router to see if the network was a problem and it works much better now. I'll try lowering the resolution now too.

jd gravatar image jd  ( 2013-03-14 16:51:44 -0500 )edit
1

answered 2013-03-10 22:04:21 -0500

I'll let Ivan Dryanovski answer about the ccny package.

I would just like to say that "tf is old" is a common error : when you play your bag file, don't forget to :

1) rosparam set /use_sim_time true

2) rosbag play with the "--clock" option

For more details, please see : here. This is a tutorial about kinect, but the principle is the same for others cameras.

Hope it'll helpo you,

Bests regards,

Steph

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-10 03:08:03 -0500

Seen: 301 times

Last updated: Mar 13 '13