ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Installation Problems

asked 2013-03-09 00:07:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi, I'm a newbee in ROS and tried several methods in installing ROS-Groovy-Desktop-Full in my ubuntu system without having really success. My system is Kubuntu 12.04, 3.2.0-39-generic. 64bit (not a vmware image)

I did the step due to: sudo apt-get install python-rosdep python-wstool build-essential --> worked, ok sudo rosdep init, rosdep update --> worked, ok mkdir ~/ros_catkin_ws, cd ~/ros_catkin_ws --> worked, ok wstool init -j8 src --> worked, ok sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -y --> worked, ok

sudo ./src/catkin/bin/catkin_make_isolated --install --> BROKEN

==> Processing plain cmake package: 'bfl' Makefile exists, skipping explicit cmake invocation... ==> make cmake_check_build_system in '/home/martin/ros_catkin_ws/build_isolated/bfl' ==> make -j4 -l4 in '/home/martin/ros_catkin_ws/build_isolated/bfl' ==> make install in '/home/martin/ros_catkin_ws/build_isolated/bfl' ==> Generating an <== Failed to process package 'bfl': 'NoneType' object has no attribute 'rfind' Command failed, exiting.

I tried the package way of installation:

martin@quadcore:~/ros_catkin_ws$ sudo apt-get install ros-groovy-desktop-full[sudo] password for martin: Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass Sie eine unmögliche Situation angefordert haben oder, wenn Sie die Unstable-Distribution verwenden, dass einige erforderliche Pakete noch nicht erstellt wurden oder Incoming noch nicht verlassen haben. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten: ros-groovy-desktop-full : Hängt ab von: ros-groovy-navigation-tutorials (= 0.1.1-s1362460629~precise) soll aber nicht installiert werden Hängt ab von: ros-groovy-slam-gmapping (= 1.2.7-s1362457898~precise) soll aber nicht installiert werden Hängt ab von: ros-groovy-navigation (= 1.10.2-s1362453401~precise) soll aber nicht installiert werden E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Not possible because of broken packages

Does anybody have an idea, or could this be a bug in the installion processing script.

Hint: A Fuerte installation in a LUbuntu VMWare worked, but I had to copy manually some deb files from the directory. The problem was: a +-00000.deb file was shown, downloaded i had a ...+ 00000.deb file. Renaming this into +-0000.deb and copying into var/cache/apt the the installation worked.

I think that the installation process is no so clean as it should be. A lot of work to do on this place.

thanks, martin

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2013-03-10 00:05:50 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


after a terrible installation process it seems to work:

Using Kubuntu 12.04 3.2.0-39-generic. 64bit base installation:

  • Open Muon or another paket manager
  • Install the paket ros-groovy-ros-full (this includes the ros-groovy documentation)
  • Install ros-groovy-visualisation

Then proceed the steps according the tutorial. If ROS_WORKSPACE is not defined (you see it using roscd) than add at the end of .bashrc the following lines:

export ROS_PACKAGE_PATH=~/catkin_ws:$ROS_PACKAGE_PATH export ROS_WORKSPACE=~/catkin_ws

(if you are using the catkin make process)

edit flag offensive delete link more

answered 2013-03-09 00:21:12 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

First, I'd suggest to install by packages if available. That usually works.

Regarding the error messages: Something is broken/inconsistent on your system. Try running sudo aptitude install ros-groovy-desktop-full.

That should identify the actual problem and give you possible solutions (review them before just accepting anything). Maybe it also helps to uninstall all ros-* packages and reinstall ros-groovy-desktop-full then.

With regard to your "fix" in fuerte installation: You should never do that. That sounds like a good way to break something.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-03-09 00:07:45 -0500

Seen: 2,976 times

Last updated: Mar 10 '13