ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

cant able to make my package [closed]

asked 2013-03-05 18:34:54 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello I'm just tried out talker/listener code in beginner tutorial

but while I make I got the following error Could you please help me to find out the solution

 mkdir -p bin
cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/groovy/share/ros/core/rosbuild/rostoolchain.cmake  ..
[rosbuild] Building package beginner_tutorials
[rosbuild] Error from directory check: /opt/ros/groovy/share/ros/core/rosbuild/bin/  /home/utp/robotics/beginner_tutorials
Traceback (most recent call last):
  File "/opt/ros/groovy/share/ros/core/rosbuild/bin/", line 46, in <module>
    raise Exception
CMake Error at /opt/ros/groovy/share/ros/core/rosbuild/private.cmake:102 (message):
  [rosbuild] rospack found package "beginner_tutorials" at "", but the
  current directory is "/home/utp/robotics/beginner_tutorials".
  You should double-check your ROS_PACKAGE_PATH to ensure that packages are
  found in the correct precedence order.
Call Stack (most recent call first):
  /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:177 (_rosbuild_check_package_location)
  CMakeLists.txt:12 (rosbuild_init)

-- Configuring incomplete, errors occurred!
make: *** [all] Error 1
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Claudio
close date 2013-03-20 01:45:31

1 Answer

Sort by ยป oldest newest most voted

answered 2013-03-05 23:54:40 -0500

Claudio gravatar image

Please learn to format code and messages correctly, that way people will find it easier to read and possibly be more willing to help you.

Have you created the workspace with rosws?

The error is saying rosbuild can't find your package among the current ROS tree. That's to say that in all the configured environment, there is nothing that points to your package.

Usually to solve such a problem you have to manually add the path:

$ rosws set /path/to/your/package

close and reopen the terminal and it should build.

In the future to check the paths in your workspace you can

$ rosws info

and to remove any

$ rosws remove
edit flag offensive delete link more

Question Tools


Asked: 2013-03-05 18:34:54 -0500

Seen: 2,476 times

Last updated: Mar 06 '13