Not able to specify use_slip_controllers:=true in pr2_tabletop_manipulation.launch [closed]

asked 2013-02-26 00:25:23 -0600

Hi,

I am using ROS electric on Ubuntu 11.10 with PR2 robot in simulation.

I am able to do object manipulation without setting use_slip_controllers:=true. As given at : http://ros.org/wiki/pr2_tabletop_manipulation_apps/Tutorials

But when I try to set this parameter to true I get an error as:-


$ roslaunch pr2_tabletop_manipulation_launch pr2_tabletop_manipulation.launch use_slip_controllers:=true
... logging to /home/nirala/.ros/log/61f677d0-800a-11e2-91bc-7071bc63a65c/roslaunch-nirala-desktop-20625.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Machine [c1] already added and does not match duplicate entry

 

Kindly let me know how can I fix it (or is it fixed in later releases). In normal operation the grasped object (a cup) slips from the robot arm after some time. I was hoping that this might be helpful in fixing it.

I googled it and tried to make changes (grouping the tfs for different arm) as given at : https://code.ros.org/trac/wg-ros-pkg/changeset/54837/stacks/pr2_object_manipulation/trunk/manipulation/pr2_object_manipulation_launch/launch/pr2_manipulation.launch but it also didn't worked.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-01-15 13:53:04.368428