Ask Your Question
0

openni_tracker fails on 12.04

asked 2013-02-20 00:52:09 -0500

jys gravatar image

http://answers.ros.org/question/42654/openninite-incompatible-in-fuerteprecise/

According to above, this should been fixed with 1.5.4.0 according to @tfoote but I am still seeing it on Fuerte/Groovy on 12.04.

[ERROR]: Find user generator failed: This operation is invalid!

And I tried the workaround proposed by @pgorczak in there but it no longer works.

Has anyone found another workaround or know how to fix it? Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-02-20 03:33:33 -0500

rastaxe gravatar image

For me the workaround worked. It was sufficient to install the linux version of NITE-dev v1.5.2.21 and the error disappeared.

edit flag offensive delete link more

Comments

If you take a look at http://www.openni.org/openni-sdk/openni-sdk-history-2/, there are 3 different things. I installed "OpenNI SDK v1.5.4.0", am I supposed to install just "NiTE v1.5.2.21" or all three?

jys gravatar image jys  ( 2013-02-20 04:26:24 -0500 )edit

I was installing the wrong thing. Installing "NITE v1.5.2.21" made it work. (It is the last one at that link) Just ran "sudo ./uninstall.sh" and "sudo ./install.sh". Thanks!

jys gravatar image jys  ( 2013-02-20 13:41:16 -0500 )edit
jys gravatar image jys  ( 2013-02-21 03:35:10 -0500 )edit

Hi, I am facing the same problem and have installed NiTE v1.5.2.21 but it still shows the same error for me. I am using ROS Groovy with Ubuntu 12.04. Any help would be appreciated.

shivesh_sk gravatar image shivesh_sk  ( 2014-05-16 16:25:32 -0500 )edit

In my experience, this method works only on 32 bit, have you a 64 bit? In this case, you have to try openni2_tracker.

rastaxe gravatar image rastaxe  ( 2014-11-14 02:54:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-20 00:52:09 -0500

Seen: 644 times

Last updated: Feb 20 '13