Ask Your Question
1

rviz symbol lookup error

asked 2013-02-13 07:49:57 -0600

Conchords gravatar image

When I attempt to launch a simulation I get a symbol lookup error and a joint state publisher panel launches but not the main rviz window. The error I get is:

/opt/ros/groovy/lib/rviz/rviz: symbol lookup error: /opt/ros/groovy/lib/librviz.so: undefined symbol: _ZN12class_loader11ClassLoader37has_unmananged_instance_been_created_E [rviz-4] process has died [pid 4967, exit code 127, cmd /opt/ros/groovy/lib/rviz/rviz -d /home/frank/Documents/Robotics/clamArm_wrkspc/clam_catkin/src/clam_bringup/launch/rviz/clam_simulation.rviz __name:=rviz __log:=/home/frank/.ros/log/d32ca0f4-7615-11e2-b08c-001c7b74b70a/rviz-4.log]. log file: /home/frank/.ros/log/d32ca0f4-7615-11e2-b08c-001c7b74b70a/rviz-4*.log

Does anyone know what causes this or how to fix it?

edit retag flag offensive close merge delete

Comments

I am getting the exact same error, if you figure it out you should post :)

rvlvrocelot gravatar imagervlvrocelot ( 2013-02-16 09:52:15 -0600 )edit

Similarly, I try to run rviz on kinetic and get the following error: /opt/ros/kinetic/lib/rviz/rviz: symbol lookup error: /opt/ros/kinetic/lib/librviz.so: undefined symbol: _ZNK9QTreeView16viewportSizeHintEv Besides, I tried "dist-upgrade" but the problem is not solved.

Yaser gravatar imageYaser ( 2017-07-25 10:52:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2013-02-26 13:33:30 -0600

hersh gravatar image

I ran into this as well. Problem is ros-groovy-class-loader is older than your ros-groovy-rviz. The complete but slow solution is:

sudo apt-get update
sudo apt-get dist-upgrade

This installs the latest version of every software package currently installed. Can take hours if you haven't done it in a while.

The faster solution which just solves this one problem is:

sudo apt-get update
sudo apt-get install ros-groovy-class-loader

The second one fixed it for me anyway. I'll start the slow one just before I leave work.

edit flag offensive delete link more

Comments

Hi Hersh, I am trying to run rviz on kinetic and I used "dist-upgrade", but it did not solve the problem. I still get: /opt/ros/kinetic/lib/rviz/rviz: symbol lookup error: /opt/ros/kinetic/lib/librviz.so: undefined symbol: _ZNK9QTreeView16viewportSizeHintEv

Yaser gravatar imageYaser ( 2017-07-25 10:54:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-13 07:49:57 -0600

Seen: 1,677 times

Last updated: Feb 26 '13