Ask Your Question
5

rosdoc_lite issues

asked 2013-02-08 13:05:46 -0600

pbeeson gravatar image

updated 2013-02-09 01:20:28 -0600

As rosdoc is deprecated, we've recently switched from rosdoc to rosdoc_lite for our private, internal documentation of not-ready-for-primetime packages.

But the web docs created by rosdoc_lite seem to ignore the (private) URLs in our manifest.xml files and just default to ros.org/wiki/ for all packages.

So, we are debating going back to dependable rosdoc, unless of course there are some undocumented tricks for rosdoc_lite that will help us out.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-02-09 06:19:36 -0600

joq gravatar image

I agree that rosdoc-lite should honor the URL specified, and not default to ros.org/wiki, even if that is the usual case.

I recommend opening a rsodoc_lite issue to get it fixed.

edit flag offensive delete link more
1

answered 2017-10-09 10:22:56 -0600

BrettHemes gravatar image

Patrick, I know this is a really old question but I recently had the same issue and it seems you can specify options such as this via yaml (see Section 2.3.2 here). Long story short, to change the linked website in the documentation just make a rosdoc.yaml file in the root directory of your package that contains the following:

- builder: doxygen
  homepage: https://my.private.url.com
edit flag offensive delete link more

Comments

This answer still holds at the moment I'm writing this.

diogoa gravatar imagediogoa ( 2018-07-17 09:57:46 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-08 13:05:46 -0600

Seen: 228 times

Last updated: Oct 09 '17