Ask Your Question
1

ROSjava subscriber

asked 2013-02-05 10:29:52 -0500

LeopoldPodmolík gravatar image

updated 2013-02-05 22:18:10 -0500

Hi,

I have problem with subscriber, when I run my android application a see in LogCat that "Unable to resolve host "ROS": No address associated with hostname".

I have set in .bashrc

ROS_IP=10.0.0.139 , ROS_HOSTNAME=10.0.0.139 , ROS_MASTER_URI=http:// 10.0.0.139:11311

In file /etc/hosts

127.0.0.1 localhost , 127.0.1.1 ROS

and in file /etc/hostname

ROS

If I create publisher it's all OK, but subscriber is still wrong. Do you know where is problem ?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2013-02-06 12:53:19 -0500

LeopoldPodmolík gravatar image

Problem solved.

The problem was in file .bashrc, where I had only

ROS_IP=10.0.0.139

when I write full command

export ROS_IP=10.0.0.139

all will be OK. I recognise by this code in shell

python -c "import roslib.network; print roslib.network.get_address_override()"

because return NONE, what was wrong ...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-05 10:29:52 -0500

Seen: 356 times

Last updated: Feb 06 '13