remote roslaunch failed to launch [closed]

asked 2013-02-01 17:40:04 -0500

dejanpan gravatar image

updated 2013-02-01 19:41:48 -0500

Dear all, I am unable to crack this one since 2 days. I have two identical laptop machines (named uldor and shagrat), with identical user accounts and would like to remotely roslaunch launch files between them. Machines are in the same well configured network, I can ssh between them without a problem.

ROS: fuerte LINUX: 12.04

Upon running the launch file on the source machine I get the following error:

started roslaunch server http://192.168.148.253:36893/ remote[uldor-0] starting roslaunch remote[uldor-0]: creating ssh connection to uldor:22 launching remote roslaunch child with command: [env ROS_MASTER_URI=http://localhost:11311 /home/demo/work/lawnmower/install/env.sh roslaunch -c uldor-0 -u http://192.168.148.253:36893/ --run_id 07005bda-6cf9-11e2-a777-606720c4eca8] remote[uldor-0]: ssh connection created [uldor-0] process has died remote roslaunch failed to launch: uldor

My uldor.machine file:

<launch>
<machine name="shagrat" address="shagrat" default="true"/>
<machine name="$(env MACHINE)" address="$(env MACHINE)" env-loader="$(env  ROS_ENV_LOADER)"/>
</launch>

The launch file that I am trying to run remotely is at the moment super simple and contains only 2 lines:

<launch>
<include file="$(find lawnmower_demos_hackathon)/launch/uldor.machine" />
<node name="tf" pkg="tf" type="tf_monitor" machine="$(env MACHINE)"/>
</launch>

Appreciate your suggestions, D.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-17 18:28:25.968600

Comments

Don't know if this helps but similar error output is discussed http://goo.gl/wzTIu

130s gravatar image 130s  ( 2013-02-03 02:27:57 -0500 )edit

Isaac, what the conclusion there is that the network has not been properly setup which is not our case. I've scanned all the posts on roslaunch remote and have not really found anyone with a similar problem. We also have PR2 robot in the same network and there this problem does not come up.

dejanpan gravatar image dejanpan  ( 2013-02-03 09:21:08 -0500 )edit