ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

cannot find custom message groovy

asked 2013-01-17 15:14:10 -0500

Poofjunior gravatar image

updated 2013-01-18 20:20:34 -0500

Hello, everyone,

I'm working to define a custom message in ROS Groovy. I've followed the tutorial and updated my CMakeLists to innclude a custom message with the following changes in my package:

  7 find_package(catkin REQUIRED COMPONENTS roscpp rospy std_msgs message_generation)

 19  add_message_files(
 20    FILES
 21    data_logger_measurement.msg
 22  )

 32  generate_messages(
 34    std_msgs
 35  )

 44 catkin_package(
 45   INCLUDE_DIRS include
 46 #  LIBRARIES tempSensorInterface 
 47   CATKIN_DEPENDS roscpp rospy std_msgs message_generation 
 48   DEPENDS system_lib message_runtime 
 49 )

I've also created a msg directory and placed the following data_logger_measurement.msg file in that directory:

Header header
float32 pressure # [C]
float32 temperature # [kPa]

(This msg is in the same package as my executable that I'm creating.)

unfortunately, when my executable includes this message with:


and when I call "make" in my build folder, I get a message that there's

No such file or directory

Am I missing another step that creates such a header file in groovy? Thanks for lending a hand on this problem!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-01-17 23:03:00 -0500

KruseT gravatar image

updated 2013-01-18 23:22:03 -0500

So, it seems there is at least a small bug in genmsg:

This bug means you have to double-check all filenames.

If your include line is:

#include <temp_sensor_interface/data_logger_measurement.h>

then make sure to check this file exists at:

ls devel/include/temp_sensor_interface

in your workspace devel folder.

Also make sure the name of your package really is temp_sensor_interface

When you change the name of the .msg file, you need to also change the CMakeLists.txt, even if it had been correct. (Make any change, like adding a blank line). Else for the .msg file, no new message will be generated. Another way to make sure, is to delete your build and devel folders, and start catkin_make again.

edit flag offensive delete link more


My mistake in posting the wrong info; my .msg file and .h are actually titled the same, but that definitely could've caused it. (I've changed the initial post above so that they reflect what my problem actually looks like.)

Poofjunior gravatar image Poofjunior  ( 2013-01-18 20:24:03 -0500 )edit

Thanks! Recreating the devel folder worked!

Poofjunior gravatar image Poofjunior  ( 2013-01-19 09:38:05 -0500 )edit

@Poofjunior if the answer solves your issue, please click the check sign so that others can easily tell that this issue is solved.

130s gravatar image 130s  ( 2013-01-19 13:22:58 -0500 )edit

Question Tools

1 follower


Asked: 2013-01-17 15:14:10 -0500

Seen: 1,893 times

Last updated: Jan 18 '13