Ask Your Question
0

Turtlebot Simulator SLAM tutorial Problem of Gazebo [closed]

asked 2013-01-08 14:21:46 -0600

Chik gravatar image

updated 2013-01-08 20:45:06 -0600

Following the Turtlebot Simulator SLAM tutorial, I copied and pasted the words from the tutorial using Gedit and created the boxes.world, robot.launch, and build_map.launch files. After that, I type roslaunch turtlebot_gazebo_tutorial build_map.launch but the Gazebo window does not show up.

When I type roslaunch turtlebot_gazebo turtlebot_empty_world.launch I can see the virtual turtlebot in the gazebo window, but when I run the build_map.launch the gazebo window does not show up, although from the terminal it seems that the program has been launched successfully. So, what is wrong?

By the way I am using VirtualBox ROS Fuerte by Nootrix. I am not sure if it means a crash of Gazebo in VirtualBox or just I need to source something to bring up the gazebo.

Thank you very much.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Chik
close date 2013-03-10 15:17:54

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-08 22:28:37 -0600

Alexandr Buyval gravatar image

I had similar problem in VirtualBox. I think, that cause of problem is that VirtualBox is not support correctly 3D graphics.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-01-08 14:21:46 -0600

Seen: 528 times

Last updated: Jan 08 '13