Ask Your Question
0

Turtlebot simulator laser scan not working.

asked 2015-07-02 19:26:03 -0600

yizheng gravatar image

updated 2015-07-02 19:26:27 -0600

Hi everyone, I'm learning ROS and I'm trying to follow this tutorial link: http://wiki.ros.org/turtlebot_simulat... , when I put several objects in the gazebo, and ran the command roslaunch turtlebot_rviz_launchers view_robot.launch. I expected to see the laser sensor and camera can read this and show their information in the Rviz, however it just gave me a blank screen without any sensory information. The image doesn't work properly either. Anybody has any ideas ? I'm using ubuntu 12.04, ROS Hydro, and gazebo 1.9.6. The global fixed frame is "base_link", the laserscan topic is /scan, and the image topic is /camera/depth/image_raw and /camera/rgb/image_raw

Thanks very much !

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-21 20:46:54 -0600

sam gravatar image

Hello, I'm also use ROS Hydro. I can work by following instruction:

export TURTLEBOT_BASE=create
export TURTLEBOT_STACKS=circles
export TURTLEBOT_3D_SENSOR=asus_xtion_pro
optirun roslaunch turtlebot_gazebo turtlebot_playground.launch

You can have a try~

Sam

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-02 19:26:03 -0600

Seen: 941 times

Last updated: Jun 21 '17