Ask Your Question
2

rviz dies with ogre exception in groovy

asked 2013-01-08 02:17:49 -0600

TommyP gravatar image

updated 2013-02-07 01:14:42 -0600

I am testing groovy. Running "rosrun rviz rviz" gives me:

terminate called after throwing an instance of 'Ogre::InternalErrorException'what():  OGRE EXCEPTION(7:InternalErrorException): Cannot compile GLSL high-level shader : rviz/include/pass_depth.geom Cannot compile GLSL high-level shader : rviz/include/pass_depth.geom (1) : error C0201: unsupported version 150 (5) : error C5060: out can't be used with non-varying depth in GLSLProgram::compile at /build/buildd/ogre-1.7.4/RenderSystems/GL/src/GLSL/src/OgreGLSLExtSupport.cpp (line 65) Aborted (core dumped)

Device Name: Quadro FX 3700/PCI/SSE2 Driver Version: 2.1.2.0

The driver is the binary driver Ubuntu 12.04 gives me.

Any ideas about this? Is the driver to old?

EDIT:

2013-02-07:

Just updated to new packages. I had to re-install the graphic drivers and I then made sure to take the recommended version (might have had version 173 before). And now rvix starts OK for me and no error messages. So either I had the wrong driver version or the recent update of the groovy packages solved the problem.

edit retag flag offensive close merge delete

Comments

I have met a similar issue, python: /build/buildd/ogre-1.7.4/OgreMain/include/OgreSingleton.h:80: Ogre::Singleton<T>::Singleton() [with T = Ogre::LogManager]: Assertion `!ms_Singleton' failed. Aborted (core dumped)

clark gravatar imageclark ( 2013-01-09 13:23:41 -0600 )edit

This was definitely a problem with rviz gracefully degrading on OS X. Please mark an answer so it shows up as answered. Thanks.

WilliamWoodall gravatar imageWilliamWoodall ( 2013-02-07 08:59:20 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-01-24 16:59:45 -0600

WilliamWoodall gravatar image

updated 2013-01-25 08:43:19 -0600

Try again with the newest version of rviz, we recently fixed a similar error on OS X:

https://github.com/ros-visualization/rviz/pull/558

EDIT:

You can get the latest rviz by updating and rebuilding your workspace:

cd ~/ros_catkin_ws
wstool merge -t src http://packages.ros.org/web/rosinstall/generate/raw/groovy/desktop --merge-replace
wstool update -t src

This command will prompt you for action at each of the packages which have changed, choose 'b' for backup and replace on each of them.

Then rebuild the stack:

rm -rf build* devel*
./src/catkin/bin/catkin_make_isolated --install

It is necessary to rebuild all of the packages because it is likely many packages (not just rviz) have changed and may affect rviz.

edit flag offensive delete link more

Comments

So how do I build the latest version? I tested downloading a zip file from the github and build in a workspace but it included files from /opt/.../rviz which seems wrong. So what are the steps to build it?

TommyP gravatar imageTommyP ( 2013-01-25 02:49:35 -0600 )edit

I updated my answer.

WilliamWoodall gravatar imageWilliamWoodall ( 2013-01-25 08:45:52 -0600 )edit
0

answered 2013-01-22 10:19:48 -0600

Ibrahim gravatar image

Well, the problem is that your graphics driver doesn't seem to support GLSL version 1.50 (OpenGL 3.2). I don't know whether there's any way to get around this besides trying to update your driver but this can be error prone in my experience (although I think nVidia binary drivers usually work better than AMD ones which are what I'm used to).

edit flag offensive delete link more

Comments

Maybe, nut I am running the driver that you get when installing the binary driver in Ubuntu 12.04. So I kind of feel that it is a bug to require more of the driver...

TommyP gravatar imageTommyP ( 2013-01-22 11:03:31 -0600 )edit

Actually it works on my machine at home installed in a similar way. I wonder than why it does not work on my machine at work. Must test tomorrow to see that the problem have not been solved by an update.

TommyP gravatar imageTommyP ( 2013-01-22 11:05:58 -0600 )edit

Actually I was probably wrong, as my machine doesn't support GLSL 1.50 either and it does spit out some errors because the shaders don't compile but it still runs. So that's probably a red herring.

Ibrahim gravatar imageIbrahim ( 2013-01-28 16:52:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-01-08 02:17:49 -0600

Seen: 616 times

Last updated: Feb 07 '13