ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

custom rosdep rules

asked 2012-12-17 09:50:50 -0600

brice rebsamen gravatar image

I am migrating to fuerte and I am having problem with rosdep 2. We have a bunch of packages and we used to have a bunch of rosdep rules to support our packages. I am wondering what I am supposed to do with rosdep2?

I tried creating /etc/ros/rosdep/sources.list.d/30-myrosdep.list with a line such as: "yaml file://path/to/my/rosdep.yaml", but it was rejected.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2012-12-17 21:36:43 -0600

updated 2012-12-17 21:39:16 -0600

Hi Brice,

the URI needs a hostname, so it should look like this:


The instructions from the official documentation tell you to first push to your forked github repo and then directly use your github links, but I prefer testing my rules locally (using a set of rules like the one above) before pushing to github.

You should still create a github account, fork the repository etc. (as explained in the page I linked to) and edit the forked files. Your sources.list.d entry should point to those files. That way, when you're satisfied, you can submit a pull request so everybody can use your rosdep rules.

edit flag offensive delete link more



It might also be a good idea to check if there already is a rule in rosdep. I found many packages actually already in there.

dornhege gravatar image dornhege  ( 2012-12-18 02:27:34 -0600 )edit

An additional slash should also work: file:///home/martin/code/rosdistro/rosdep/base.yaml.

joq gravatar image joq  ( 2012-12-18 07:13:14 -0600 )edit

@joq: It should, but it doesn't. Rosdep insists on a hostname even for file:// schemes; this is a bug in rosdep.

Martin Günther gravatar image Martin Günther  ( 2012-12-18 21:56:51 -0600 )edit

Question Tools

1 follower


Asked: 2012-12-17 09:50:50 -0600

Seen: 841 times

Last updated: Dec 17 '12